Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1603776 - kernel 4.17.x / Lenovo X1: immediate wakeup after suspend
Summary: kernel 4.17.x / Lenovo X1: immediate wakeup after suspend
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-19 18:50 UTC by Phil
Modified: 2018-09-21 13:53 UTC (History)
19 users (show)

Fixed In Version: kernel-4.18.5-200.fc28.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-21 13:53:10 UTC


Attachments (Terms of Use)
Fresh boot on kernel 4.17.18-200.fc28.x86_64 (deleted)
2018-08-29 21:34 UTC, MartinG
no flags Details
first suspend, successful (deleted)
2018-08-29 21:35 UTC, MartinG
no flags Details
second suspend, failing - resulting in immediate resume (deleted)
2018-08-29 21:36 UTC, MartinG
no flags Details

Description Phil 2018-07-19 18:50:07 UTC
Description of problem:
laptop wakes up right after suspend

Version-Release number of selected component (if applicable):
4.17.x (verified with 4.17.5 and 4.17.6)

How reproducible:
frequently

Steps to Reproduce:
1. close lid
2. wait

Actual results:
laptop wakes up almost immediately

Expected results:
laptop stays in suspend

Additional info:
works fine with kernel 4.16.x

output of dmidecode -t 0,1
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x000D, DMI type 1, 27 bytes
System Information
	Manufacturer: LENOVO
	Product Name: 20A7008JGE
	Version: ThinkPad X1 Carbon 2nd
	Serial Number: xxx
	UUID: xxx
	Wake-up Type: Power Switch
	SKU Number: LENOVO_MT_20A7_BU_Think_FM_ThinkPad X1 Carbon 2nd
	Family: ThinkPad X1 Carbon 2nd

Handle 0x002F, DMI type 0, 24 bytes
BIOS Information
	Vendor: LENOVO
	Version: GRET53WW (1.30 )
	Release Date: 09/21/2017
	Address: 0xE0000
	Runtime Size: 128 kB
	ROM Size: 8192 kB
	Characteristics:
		PCI is supported
		PNP is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported
		Targeted content distribution is supported
		UEFI is supported
	BIOS Revision: 1.30
	Firmware Revision: 1.19


output of journalctl -efk:
Jul 19 20:38:41 x kernel: wlp3s0: deauthenticating from aa:bb:cc:dd:ee:ff by local choice (Reason: 3=DEAUTH_LEAVING)
Jul 19 20:38:41 x kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
Jul 19 20:38:46 x kernel: PM: suspend entry (deep)
Jul 19 20:38:46 x kernel: PM: Syncing filesystems ... done.
Jul 19 20:38:51 x kernel: Freezing user space processes ... (elapsed 0.002 seconds) done.
Jul 19 20:38:51 x kernel: OOM killer disabled.
Jul 19 20:38:51 x kernel: Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
Jul 19 20:38:51 x kernel: Suspending console(s) (use no_console_suspend to debug)
Jul 19 20:38:51 x kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Jul 19 20:38:51 x kernel: sd 0:0:0:0: [sda] Stopping disk
Jul 19 20:38:51 x kernel: e1000e: EEE TX LPI TIMER: 00000011
Jul 19 20:38:51 x kernel: PM: suspend devices took 2.088 seconds
Jul 19 20:38:51 x kernel: ACPI: EC: interrupt blocked
Jul 19 20:38:51 x kernel: ACPI: Preparing to enter system sleep state S3
Jul 19 20:38:51 x kernel: ACPI: EC: event blocked
Jul 19 20:38:51 x kernel: ACPI: EC: EC stopped
Jul 19 20:38:51 x kernel: PM: Saving platform NVS memory
Jul 19 20:38:51 x kernel: Disabling non-boot CPUs ...
Jul 19 20:38:51 x kernel: smpboot: CPU 1 is now offline
Jul 19 20:38:51 x kernel: smpboot: CPU 2 is now offline
Jul 19 20:38:51 x kernel: smpboot: CPU 3 is now offline
Jul 19 20:38:51 x kernel: ACPI: Low-level resume complete
Jul 19 20:38:51 x kernel: ACPI: EC: EC started
Jul 19 20:38:51 x kernel: PM: Restoring platform NVS memory
Jul 19 20:38:51 x kernel: Enabling non-boot CPUs ...
Jul 19 20:38:51 x kernel: x86: Booting SMP configuration:
Jul 19 20:38:51 x kernel: smpboot: Booting Node 0 Processor 1 APIC 0x1
Jul 19 20:38:51 x kernel:  cache: parent cpu1 should not be sleeping
Jul 19 20:38:51 x kernel: CPU1 is up
Jul 19 20:38:51 x kernel: smpboot: Booting Node 0 Processor 2 APIC 0x2
Jul 19 20:38:51 x kernel:  cache: parent cpu2 should not be sleeping
Jul 19 20:38:51 x kernel: CPU2 is up
Jul 19 20:38:51 x kernel: smpboot: Booting Node 0 Processor 3 APIC 0x3
Jul 19 20:38:51 x kernel:  cache: parent cpu3 should not be sleeping
Jul 19 20:38:51 x kernel: CPU3 is up
Jul 19 20:38:51 x kernel: ACPI: Waking up from system sleep state S3
Jul 19 20:38:51 x kernel: ACPI: EC: interrupt unblocked
Jul 19 20:38:51 x kernel: ACPI: EC: event unblocked
Jul 19 20:38:51 x kernel: sd 0:0:0:0: [sda] Starting disk
Jul 19 20:38:51 x kernel: usb 1-1.5: reset full-speed USB device number 3 using ehci-pci
Jul 19 20:38:51 x kernel: ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd ef/10:09:00:00:00:a0 (SET FEATURES) succeeded
Jul 19 20:38:51 x kernel: PM: resume devices took 0.322 seconds
Jul 19 20:38:51 x kernel: OOM killer enabled.
Jul 19 20:38:51 x kernel: Restarting tasks ... done.
Jul 19 20:38:51 x kernel: ata1.00: NCQ Send/Recv Log not supported
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
Jul 19 20:38:51 x kernel: ata1.00: ACPI cmd ef/10:09:00:00:00:a0 (SET FEATURES) succeeded
Jul 19 20:38:51 x kernel: ata1.00: NCQ Send/Recv Log not supported
Jul 19 20:38:51 x kernel: ata1.00: configured for UDMA/133
Jul 19 20:38:51 x kernel: PM: suspend exit
Jul 19 20:38:51 x kernel: e1000e: enp0s25 NIC Link is Down
Jul 19 20:38:51 x kernel: IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
Jul 19 20:38:51 x kernel: IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
Jul 19 20:38:51 x kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
Jul 19 20:38:51 x kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
Jul 19 20:38:52 x kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
Jul 19 20:38:55 x kernel: wlp3s0: authenticate with aa:bb:cc:dd:ee:ff
Jul 19 20:38:55 x kernel: wlp3s0: send auth to aa:bb:cc:dd:ee:ff (try 1/3)
Jul 19 20:38:55 x kernel: wlp3s0: authenticated
Jul 19 20:38:55 x kernel: wlp3s0: associate with aa:bb:cc:dd:ee:ff (try 1/3)
Jul 19 20:38:55 x kernel: wlp3s0: RX AssocResp from aa:bb:cc:dd:ee:ff (capab=0x831 status=0 aid=1)
Jul 19 20:38:55 x kernel: wlp3s0: associated
Jul 19 20:38:55 x kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready

Comment 1 Phil 2018-08-09 17:36:54 UTC
4.17.12-200.fc28.x86_64 is still affected.

Comment 2 Sébastien Wilmet 2018-08-23 13:41:56 UTC
I have the same problem with a Lenovo ThinkPad L530.

It's a regression since kernel 4.17, 4.16 works fine.

4.17.14-202.fc28.x86_64 is still affected.

Comment 3 Sébastien Wilmet 2018-08-23 14:10:26 UTC
I've opened this upstream bug report:
https://bugzilla.kernel.org/show_bug.cgi?id=200909

Comment 4 MartinG 2018-08-29 21:33:03 UTC
Confirming this.
I have a thinkpad T430, and suspend (to ram) has worked just fine forever, including kernel 4.16. After updating to kernel 4.17.x I have had this problem:
First suspend works as expected, but the second time I suspen (by closing lid, or by pressing the suspend button (Fn+F4)) the system wakes up immediately.

I will attach three dumps of dmesg -T from kernel 4.17.18-200.fc28.x86_64:
1) after fresh boot
2) after first successful suspend manually initiated resume
3) second suspend attempt resulting in immediate resume

Comment 5 MartinG 2018-08-29 21:34:26 UTC
Created attachment 1479601 [details]
Fresh boot on kernel 4.17.18-200.fc28.x86_64

Comment 6 MartinG 2018-08-29 21:35:15 UTC
Created attachment 1479602 [details]
first suspend, successful

Comment 7 MartinG 2018-08-29 21:36:33 UTC
Created attachment 1479603 [details]
second suspend, failing - resulting in immediate resume

Comment 8 MartinG 2018-08-29 22:01:27 UTC
Probably related to my issue: https://bugzilla.kernel.org/show_bug.cgi?id=200455

Will try adding
blacklist mei_me
to /etc/modprobe.d/blacklist

Comment 9 MartinG 2018-08-31 19:15:42 UTC
Hva tested with 4.17.19-200.fc28.x86_64 now. The problem persists.
It does not help to remove mei_wdt, mei_me and mei before suspending.
I tried to remove those three modules (no other mei modules listed) after a fresh boot, and also added "blacklist mei" in /etc/modprobe.d/blacklist.

The first suspend worked, but the second attempt resulted in immediate wake up like before.

Going back to kernel-4.16.3-301.fc28.x86_64 which works.

Comment 10 Phil 2018-09-17 19:56:56 UTC
Looks like with kernel-4.18.5-200.fc28.x86_64 and 4.18.7-200.fc28.x86_64 the problem does not persist.

Comment 11 Jeremy Cline 2018-09-21 13:53:10 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.