Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160372 - Dependency problem with Sun Java 1.5.0 RPM
Summary: Dependency problem with Sun Java 1.5.0 RPM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 19:30 UTC by Fred New
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.9.112
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 08:56:09 UTC


Attachments (Terms of Use)

Description Fred New 2005-06-14 19:30:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I am unable to install Sun's jre-1.5.0_03-fcs RPM because of dependency problems with openoffice.org-core and jessie.

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 with openoffice.org-core-1.9.104-2 and jessie-1.0.0-8
2. Attempt to install Sun's jre-1.5.0_03-fcs (i586) RPM.  

Actual Results:  # rpm -Uvh jre-1_5_0_03-linux-i586.rpm
error: Failed dependencies:
        java >= 0:1.4 is needed by (installed) jessie-1.0.0-8.noarch
        java-1.4.2-gcj-compat is needed by (installed) openoffice.org-core-1.9.104-2.i386
#

Expected Results:  # rpm -Uvh jre-1_5_0_03-linux-i586.rpm
Preparing...                ########################################### [100%]
   1:jre                    ########################################### [100%]
#

Additional info:

Workaround:  Install j2re-1_4_2_08-linux-i586.rpm from Sun.

Comment 1 Fred New 2005-06-14 21:26:58 UTC
I spoke too soon about  j2re-1.4.2_08 - I can't get its plugin to work in
Firefox.  So it doesn't look like there is a workaround for this problem, unless
the open source java can provide a secure plugin.

Comment 2 Caolan McNamara 2005-06-14 23:05:07 UTC
well our Ooo is built against libgcj and requires that, though that said I think
it might not be necessary to Require java-1.4.2-gcj-compat. I'll see if we can
drop that Require.

Comment 3 djh 2005-06-15 04:14:36 UTC
This is documented in the release notes.

http://fedora.redhat.com/docs/release-notes/fc4/#id2503931

"Fedora Core 4 users are advised not to use the Java RPM provided by Sun..."

Comment 4 Fred New 2005-06-15 06:50:19 UTC
Oops. I was thinking I had probably missed something. It's fine with me if this
is closed as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.