Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160364 - vpnc does not change the routing tables properly
Summary: vpnc does not change the routing tables properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vpnc
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL: http://lists.unix-ag.uni-kl.de/piperm...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 18:58 UTC by Jeff Orcutt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 18:21:08 UTC


Attachments (Terms of Use)

Description Jeff Orcutt 2005-06-14 18:58:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
From Mailing list:

Hi,

when i updated to vpnc 0.3.3 and tried to launch i got the following error:

Error: either "to" is duplicate, or "64" is a garbage.

To resolve this i had to change

sed 's/cache//;s/metric[0-9]\+ [0-9]\+//g'

to

sed 's/cache//;s/metric [0-9]\+ [0-9]\+//g'

within the  fix_ip_get_output function.

Bye
Sumedha


This change in /etc/vpnc/vpnc-script was necessary for me to connect to my campus VPN.  Before it would make the connection just hang.  It works now after this change.

Version-Release number of selected component (if applicable):
vpnc-0.3.3-2

How reproducible:
Always

Steps to Reproduce:
1.Install vpnc and configure it
2.sudo vpnc; get error message
3.open firefox


Actual Results:  no web page displayed

Expected Results:  should be connected

Additional info:

Comment 1 Tomas Mraz 2005-06-15 12:01:40 UTC
Your solution would break on other machines.

More correct would be: sed 's/cache//;s/metric[ 0-9]\+//g'


Comment 2 Tomas Mraz 2005-06-15 18:21:08 UTC
Should be fixed in the next vpnc builds for devel and FC4 extras.


Note You need to log in before you can comment on or make changes to this bug.