Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160358 - kernel hung after isapnp on stl2 motherboard
Summary: kernel hung after isapnp on stl2 motherboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 17:25 UTC by Rob Hagopian
Modified: 2015-01-04 22:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-05 22:25:23 UTC


Attachments (Terms of Use)

Description Rob Hagopian 2005-06-14 17:25:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When using the stock FC4 cd on an STL2 motherboard (more machine details below) hangs (really really hard) after the report that isapnp finds no plug and play cards. When I use the boot.iso in the development tree it hangs for a moment or two and then panics (trace below).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert CD
2. Boot
3. Wait for crash
  

Actual Results:  Hang (fc4 stock) or kernel panic (6/14 development boot.iso)

Expected Results:  Should have booted to anaconda

Additional info:

I'll call this normal priority despite the crash since it's likely very specific to this motherboard (reminiscent of the L440GX problems :-) ); install worked great on a sony laptop.

Machine specifics: Intel STL-2 motherboard, 2x1Ghz PIII, 4G RAM, PCI nvidia video, PCI dual channel symbios, PCI dual gig-e, and PCI initio-9100, onboard video disabled, tried with onboard usb both enabled and disabled [since normal kernel log shows usb after isapnp]. Currently running a personally compiled EL3 (from SRPMS) with custom kernel 2.6.8.1.

Here's the trace data from the development boot.iso:

[<c01002a0>] init+0x0/0xf0
[<c01002bd>] init+0x1d/0xf0
[<c01012b1>] kernel_thread_helper+0x5/0x14
[<c014d747>] softlockup_tick+0x87/0x160
[<c0108a93>] timer_interrupt+0x63/0x170
[<c014d9c3>] handle_IRQ_event+0x33/0x60
[<c014daac>] __do_irq+0xbc/0x2c0
[<c0105a81>] do_irq+0x51/0x90
=======================
[<c0103c4a>] common_interrupt+0x1a/0x20
[<c0127361>] __do_softirq+0x31/0xa0
[<c0105b8e>] do_softirq+0x3e/0x50
=======================
[<c0105a88>] do_irq+0x58/0x90
[<c0103c4a>] common_interrupt+0x1a/0x20
[<c015007b>] __generic_file_aio_read+0x1db/0x210
[<c014e071>] setup_irq+0xe1/0x210
[<c0262090>] rtc_interrupt+0x0/0x2f0
[<c014e420>] request_irq+0x80/0xa0
[<c042c777>] rtc_init+0x47/0x2e0
[<c041528d>] do_initcalls+0x4d/0xb0
[<c01002a0>] init+0x0/0xf0
[<c01002bd>] init+0x1d/0xf0
[<c01012b1>] kernel_thread_helper+0x5/0x14

Comment 1 Chuck Joslin 2005-06-14 18:26:54 UTC
Confirmed as a problem on my STL-2 motherboard. Dual 866MHz PIII, 1GB RAM, no
add-in cards.

Comment 2 Matthew Costello 2005-06-16 03:15:26 UTC
Confirmed as a problem on my Intel ISP 2150: Dual 1GHz PIII, 1GB RAM, SCSI.
1. Install from CD hangs right after isapnp test.
   Still hangs with "noprobe" and/or "noisapnp".
2. Installed FC4 kernel (2.6.11-1.1369_FC4) by installing fedora-release rpm 
   and "yum upgrade kernel". It now hangs immediately after:
 "Uncompressing Linux... Ok, booting the kernel."

I don't know if this has anything to do with it, but when booting the FC3
kernel I get two copies of the following warning:
 "agpgart: unable to determine aperture size."

[output of /sbin/lspci (using FC3)]
00:00.0 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:00.1 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:02.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC 215IIC
[Mach64 GT IIC] (rev 7a)
00:03.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
00:06.0 Ethernet controller: Intel Corp. 82541GI/PI Gigabit Ethernet Controller
00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 50)
00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 04)
01:04.0 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
01:04.1 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)


Comment 3 Andrzej 2005-06-16 12:26:10 UTC
I have the same problem!
My configuration:
STL2, 1.256GB RAM, AHA 2200S, 8xHDD, Matrox G200 PCI 8MB RAM.
Probably this is the AGP problem.
After PNP devices kernel check AGP version & aperture size.


Comment 4 Garry Thorpe 2005-06-17 08:50:58 UTC
I also have the same problem!
My configuration:
NEC Express 5800/120Ef.  It has a ServerWorks GC-SL motherboard.
1x2.8G Xeon, 1GB RAM, onboard video and network.
(see http://www.nec.co.jp/express/products/brochure/120Ef_Product_guide.pdf)  
No idea if this is relevant but...
There is a string of messages at the top of the screen with:
pnp: 00-07: ioport range 0x580 to 0x58d has been reserved
pnp: 00-07: ioport range 0xb04 to 0xb04 has been reserved
pnp: 00-07: ioport range 0x419 to 0x41b has been reserved  (total 7 of them)
I have FC3 installed fine, had the same problem with a FC4 test and FC4


Comment 5 Garry Thorpe 2005-06-19 12:35:31 UTC
I found a suggestion to try:
linux acpi=off at the boot prompt during install.
This allowed the installation to proceed successfully.
(thanks to Klaus Kruger [kkruger@tecs-company.com])



Comment 6 Rob Hagopian 2005-06-20 12:57:37 UTC
Indeed - works for me. Thanks!

Comment 7 Andrzej 2005-06-27 11:51:11 UTC
OK! Working, but this is not good idea.
Now I don't have any sensors รข temperature, fan...

Comment 8 Dave Jones 2005-07-15 21:54:23 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 9 Rob Hagopian 2005-08-05 14:42:59 UTC
Works for me - I simply removed acpi=off and all's good now. Thanks!


Note You need to log in before you can comment on or make changes to this bug.