Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160357 - printing results in garbage output
Summary: printing results in garbage output
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 17:17 UTC by Thilo Pfennig
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-22 19:01:23 UTC


Attachments (Terms of Use)
Test case with traditional Chinese characters (deleted)
2005-10-28 13:16 UTC, Scott Tsai
no flags Details

Description Thilo Pfennig 2005-06-14 17:17:45 UTC
Description of problem:

I have tried to print a PDF file that can be found at:
http://www.gnome-ev.de/images/d/df/Mitgliedsantrag_GNOME.pdf
I can print Ok with XPDF but on Evince many things ar garbage

Version-Release number of selected component (if applicable):
evince-0.3.1-1


How reproducible:

always

Steps to Reproduce:
1. open document http://www.gnome-ev.de/images/d/df/Mitgliedsantrag_GNOME.pdf
2. print
  
Actual results:

garbage on paper

Expected results:

nice printout

Additional info:

I also habe the problem to deinstall old packages like 
evince-0.2.1-1, but the binary I use to open is 0.3.1.

Comment 1 Gregory Gulik 2005-06-20 16:17:16 UTC
Another example of garbled printing can be produced when printing the following
PDF file from evince:
http://www.chicityclerk.com/residential_parking/residential_parking_web.pdf

Printing on any of the three printers I have access to results in completely
garbled text.

Comment 2 Johan Dahl 2005-06-23 09:31:45 UTC
Evince also have problems printing umlaut characters (åäö) They show up as empty
spaces.

Comment 3 John Reiser 2005-07-11 13:44:03 UTC
http://sambanotes.org/Parent%20Meeting%20Hand-0ut.pdf  also prints as garbage;
display is OK.  181KB, 4 page Letter document, all text (no images), probably
one embedded font.  There is no "print to file" option to save PostScript, but
output is trash (sparse text in Courier font, 5 lines per inch, many
dollar/number/parenthesis/digit/unerlined characters) on HP LaserJet 4ML printer
with true Adobe PostScript engine in the printer.

Comment 4 Scott Tsai 2005-10-28 13:16:54 UTC
Created attachment 120504 [details]
Test case with traditional Chinese characters

With:
evince-0.4.0-1.2
libgnomeprint22-2.10.3-1
libgnomeprintui22-2.10.1-1

The attached pdf with embeded traditional Chinese fonts render properly, but
'File'->'Print'->'Generic Postscript'->'Save as' produces a ps file that
renders incorrectly. Using pdftops from xpdf produces a ps file that renders
correctly.

Same story with printing, lpr works but printing directly from libgnomeprintui
produces the same incorrect output. Diffing the two ps files show that evince
does not include the needed font data in its postscript output.

Comment 5 Scott Tsai 2006-05-13 08:52:05 UTC
As of evince-0:0.5.1-3.x86_64 on fc5,
printing of "Mitgliedsantrag_GNOME.pdf", "Parent Meeting Hand-0ut.pdf" and
"test_chinese.pdf" seems to have all been fixed.

Comment 6 Kristian Høgsberg 2006-09-22 19:01:23 UTC
Using poppler-0.5.4 and evince-0.5.5, I can't reproduce this anymore.  Closing bug.



Note You need to log in before you can comment on or make changes to this bug.