Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160335 - Installer crashes with python/anaconda errors when using a personalised kickstart file over NFS
Summary: Installer crashes with python/anaconda errors when using a personalised kicks...
Keywords:
Status: CLOSED DUPLICATE of bug 160209
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 15:06 UTC by stef
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-14 15:49:22 UTC


Attachments (Terms of Use)
full dump of anaconda report (deleted)
2005-06-14 15:10 UTC, stef
no flags Details

Description stef 2005-06-14 15:06:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
The anaconda installer crashes with python error outputs when trying to install packages selected in a kickstart file read over NFS.
The kickstart file is personnalised to suit the system install needs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot with   linux ks=nfs:server:/path/to/kickstart/
2.anaconda crashes and ask if we want to make an output on a floppy drive
3.reboot (no other thing to do)
  

Actual Results:  installation fails, output :

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1160, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line 447, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 279, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 207, in readPackages
    id.instClass.setGroupSelection(grpset, intf)
  File "/usr/lib/anaconda/kickstart.py", line 1559, in setGroupSelection
    pkgs = grpset.hdrlist.pkgnames[name]
KeyError: ''


Expected Results:  installation runs automatically

Additional info:

kickstart file personnalised with lines like thoses for packages selection (short example):

@ admin-tools
@ printing
@ java
kernel-devel
subversion
lvm2
ElectricFence
xorg-x11-sdk
-gaim
-evolution

Comment 1 stef 2005-06-14 15:09:34 UTC
the kickstart and the installer runs fine with FC4test2 and FC4test3

Comment 2 stef 2005-06-14 15:10:42 UTC
Created attachment 115412 [details]
full dump of anaconda report

Comment 3 stef 2005-06-14 15:18:50 UTC
found the issue!

same error than in bug 160209, when using package description with minus sign
like "-evolution", menaning "don't install evolution package", the installer
crashes.

Comment 4 Chris Lumens 2005-06-14 15:49:22 UTC

*** This bug has been marked as a duplicate of 160209 ***


Note You need to log in before you can comment on or make changes to this bug.