Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1603163 - Can't collect logs to subfolder using anonymous ftp connection
Summary: Can't collect logs to subfolder using anonymous ftp connection
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: 5.10.0
Assignee: Joe Rafaniello
QA Contact: Dave Johnson
URL:
Whiteboard: appliance:depot:maintenance
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-19 10:47 UTC by Ruslana Babyuk
Modified: 2018-08-01 14:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 16:54:58 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
log (deleted)
2018-07-19 10:47 UTC, Ruslana Babyuk
no flags Details

Description Ruslana Babyuk 2018-07-19 10:47:01 UTC
Created attachment 1459990 [details]
log

Description of problem:
Can't collect logs to subfolder using anonymous ftp connection

Version-Release number of selected component (if applicable):
5.10

How reproducible:
100%

Steps to Reproduce:
1. Use anonymous ftp depot with empty incoming folder
2. Configure log collection URI, like this ftp://10.8.59.219/incoming
3. Collect current logs

Actual results:
Can't create a folder. Log collection failed. See error attached screen


Expected results:
Log was collected

Comment 3 Joe Rafaniello 2018-07-19 18:28:08 UTC
Hi Ruslana,

1) Can you ftp to this URI using the same user from another ftp client?  
2) What version of 5.10 is this?  cat /var/www/miq/vmdb/version or provide the rpm -qi cfme.
3) Does this work on 5.9 or 5.8?
4) What ftp server are you using?
5) Are you able edit the ftp credentials and click "validate"?

Can you provide debug logs of your ftp server and the full evm.log for this case and also do it for step 5).

If you're using vsftpd, it's very complicated to get the permissions correct.

Comment 4 Joe Rafaniello 2018-07-19 18:37:59 UTC
I ask if 5.9/5.8 have this issue because there was a refactoring that landed in 5.10 around log collection:  https://github.com/ManageIQ/manageiq/pull/17437

We won't know what's causing this until we verify the permissions are correct.

Comment 5 Ruslana Babyuk 2018-07-25 08:47:07 UTC
Hi Joe,

Looks like this is a permission issue as you told above, I tried 5.9 and also get the same error.
And I'm using vsftpd for tests
For anonymous ftp connection, we don't have validate button.
I'll try to check permissions, and let you know

Comment 6 Joe Rafaniello 2018-07-31 16:54:58 UTC
Closing for now, we can reopen if you get vsftpd working for normal ftp clients and it fails for manageiq/cfme.  If you do reopen the bug, please provide debug logging from the vsftpd side when it works for a normal ftp client (create directories and put a file in those created directories) vs. when it fails for cfme.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.