Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160314 - cpio lacks large file support
Summary: cpio lacks large file support
Keywords:
Status: CLOSED DUPLICATE of bug 154507
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cpio
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Vrabec
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 11:51 UTC by Steffen Schoenwiese
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 11:04:51 UTC


Attachments (Terms of Use)

Description Steffen Schoenwiese 2005-06-14 11:51:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 SUSE/1.0.4-1.1

Description of problem:
cpio lacks support for files larger than 2 GB:

[root@em2:test]$dd if=/dev/zero of=large_file bs=1024 count=2100000
[root@em2:test]$ls -lah
total 2.1G
drwxr-xr-x  2 root root 4.0K Jun 14 13:58 .
drwxrwxrwt  7 root root 4.0K Jun 14 13:55 ..
-rw-r--r--  1 root root 2.1G Jun 14 13:33 large_file

[root@em2:test]$ls | cpio -ov > test.cpio
cpio: large_file: Value too large for defined data type
cpio: test.cpio: truncating inode number
test.cpio
1 block

[root@em2:test]$ls -lah
total 2.1G
drwxr-xr-x  2 root root 4.0K Jun 14 13:58 .
drwxrwxrwt  7 root root 4.0K Jun 14 13:55 ..
-rw-r--r--  1 root root 2.1G Jun 14 13:33 large_file
-rw-r--r--  1 root root  512 Jun 14 13:58 test.cpio


Version-Release number of selected component (if applicable):
cpio-2.5-7.EL4.1

How reproducible:
Always

Steps to Reproduce:
1. create a large file (dd if=/dev/zero of=large_file bs=1024 count=2100000)
2. do ls | cpio -ov > test.cpio

  

Actual Results:  cpio shows an error message and the resulting file is way too small

Expected Results:  No error and a complete cpio-file

Additional info:

Comment 1 Jussi Silvennoinen 2005-06-20 20:46:21 UTC
I think you're testing with cpio-2.5-7, this was fixed in cpio-2.5-7.EL4.1 and I
can run those commands just fine without problems.

Comment 2 Steffen Schoenwiese 2005-06-21 10:33:04 UTC
Well, "rpm -q -f /bin/cpio" says, it belongs to cpio-2.5-7.EL4.1, which should
be the fixed one. But the problem remains, just checked it again.

Comment 3 Peter Vrabec 2005-06-23 11:04:51 UTC
It's fixed in cpio-2.5-7.EL4.2.

*** This bug has been marked as a duplicate of 154507 ***


Note You need to log in before you can comment on or make changes to this bug.