Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160308 - USB Key stops working after upgrade to U1
Summary: USB Key stops working after upgrade to U1
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i686
OS: Linux
Target Milestone: ---
: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
Depends On:
Blocks: 168429
TreeView+ depends on / blocked
Reported: 2005-06-14 10:53 UTC by Dirk Gfroerer
Modified: 2007-11-30 22:07 UTC (History)
8 users (show)

Fixed In Version: RHSA-2006-0132
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-03-07 19:08:05 UTC
Target Upstream Version:

Attachments (Terms of Use)
Output in /var/log/messages with kernel-2.6.9-11 (deleted)
2005-06-14 10:55 UTC, Dirk Gfroerer
no flags Details
Output of /var/log/messages with kernel 2.6.9-5.0.5 (deleted)
2005-06-14 10:57 UTC, Dirk Gfroerer
no flags Details
Output of lsusb -v with kernel-2.6.9-5.0.5 (deleted)
2005-06-14 10:59 UTC, Dirk Gfroerer
no flags Details
Output of lspci -v (deleted)
2005-06-14 10:59 UTC, Dirk Gfroerer
no flags Details
dmesg output of kernel -11. (deleted)
2005-06-14 17:07 UTC, Dirk Gfroerer
no flags Details
dmesg output of kernel -5.0.5 (deleted)
2005-06-14 17:08 UTC, Dirk Gfroerer
no flags Details
/proc/bus/usb/devices of -11 kernel (deleted)
2005-06-14 17:08 UTC, Dirk Gfroerer
no flags Details
Picture1 of USB Key (deleted)
2005-07-07 06:54 UTC, Dirk Gfroerer
no flags Details
Picture 2 of USB Key (deleted)
2005-07-07 06:54 UTC, Dirk Gfroerer
no flags Details
Candidate #1 - only clear halt after an error (deleted)
2005-11-01 00:18 UTC, Pete Zaitcev
no flags Details | Diff

System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2005:808 normal SHIPPED_LIVE Important: kernel security update 2005-10-27 04:00:00 UTC
Red Hat Product Errata RHSA-2006:0132 qe-ready SHIPPED_LIVE Moderate: Updated kernel packages available for Red Hat Enterprise Linux 4 Update 3 2006-03-09 16:31:00 UTC

Description Dirk Gfroerer 2005-06-14 10:53:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
I've got a KINGSTON USB memory stick which I just plug into my machine and automatically an entry is created in /etc/fstab. This worked fine with RHEL 3 (with different updates) and also worked properly with RHEL 4. However after having upgraded to U1 this weekend, the kernel no longer configures the USB memory stick any more. When I boot with the previous kernel (i.e. kernel-2.6.9-5.0.5.EL) the stick gets configured properly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. But kernel-2.6.9-11.EL
2. Plug in memory stick


Actual Results:  Kernel sees stick but fails to configure it.

Expected Results:  Kernel detects memory stick and configures it as previously.

Additional info:

The machine is a Dell Dimension 4550.

Comment 1 Dirk Gfroerer 2005-06-14 10:55:50 UTC
Created attachment 115396 [details]
Output in /var/log/messages with kernel-2.6.9-11

Comment 2 Dirk Gfroerer 2005-06-14 10:57:25 UTC
Created attachment 115397 [details]
Output of /var/log/messages with kernel 2.6.9-5.0.5

Comment 3 Dirk Gfroerer 2005-06-14 10:59:12 UTC
Created attachment 115398 [details]
Output of lsusb -v with kernel-2.6.9-5.0.5

Comment 4 Dirk Gfroerer 2005-06-14 10:59:57 UTC
Created attachment 115399 [details]
Output of lspci -v

Comment 5 Pete Zaitcev 2005-06-14 16:20:29 UTC
This is a regression, clearly. Thanks for letting me know.

I would like to see complete dmesg outputs for the two kernels involved,
taken with the key attached.

BTW, I cannot call this device a "memory stick", because Memory Stick(r)
is a trademark of Sony, and in any case it means entirely different technology
that has nothing to do with USB. "USB key" is a common term.

Comment 6 Pete Zaitcev 2005-06-14 16:37:29 UTC
Also, I need /proc/bus/usb/devices, but one would be enough - they should
be the same on both kernels.

Comment 7 Dirk Gfroerer 2005-06-14 17:07:21 UTC
Created attachment 115417 [details]
dmesg output of kernel -11.

I've waited for the machine to boot up completely (i.e. enter runlevel 5) then
inserted the USB key. Waited for about 20 seconds than ran dmesg.

Comment 8 Dirk Gfroerer 2005-06-14 17:08:12 UTC
Created attachment 115418 [details]
dmesg output of kernel -5.0.5

Same procedure as with -11 kernel.

Comment 9 Dirk Gfroerer 2005-06-14 17:08:46 UTC
Created attachment 115419 [details]
/proc/bus/usb/devices of -11 kernel

Comment 10 Fabien MARTY 2005-06-22 09:47:37 UTC
exactly the same problem for me (ok with the old kernel, notok for the new, same
logs than Dirk)

Comment 11 Roderick Johnstone 2005-07-05 11:07:31 UTC
Me too, for my Kingston DataTraveler2.0, but the TwinMOS MOBILE Disk seems to
work ok.

Comment 12 Pete Zaitcev 2005-07-06 19:04:06 UTC
It appears that Kingston offers no less than 4 generations of USB keys.
Here's the list of 512MB units (Dirk has 512MB):
#1: KUSBDTI/512
#2: KUSBDTII/512
#3: KUSBDTII+/512
The 4th gen either has no 512MB, or CDW doesn't carry it, so the 1GB unit:

I had a case when Warren sent me a key which failed for him but worked
just fine here, so I don't want any risks.

Guys, please read the signage off the bottom of your keys and post it here.
A readable digital picture would work too.

Comment 13 Dirk Gfroerer 2005-07-07 06:54:11 UTC
Created attachment 116459 [details]
Picture1 of USB Key

Comment 14 Dirk Gfroerer 2005-07-07 06:54:54 UTC
Created attachment 116460 [details]
Picture 2 of USB Key

Comment 15 Dirk Gfroerer 2005-07-07 07:05:12 UTC
None of the four links showed the USB key I'm using. The key is not a current
model. It was purchased on 2004-07-12. There's a barely readable signage at the
side of the key which reads: 4083G9008014R233A1.
I plugged the key in the meantime in three other machines which are running RHEL
4 (two with an USB 1.1 bus, one with an USB 2.0 capable bus). It worked in none
of them.
I've also tested with a KINGSTON DataTraveler II+ and this key worked fine.

Comment 16 Pete Zaitcev 2005-07-07 07:14:48 UTC
Surely you mean "plugged into ... running RHEL 4 U1", because you wrote that
RHEL 4 GA worked in the original report?

Comment 17 Dirk Gfroerer 2005-07-07 07:17:20 UTC
Yes, sorry. All machines were running RHEL 4 U1.

Comment 18 Roderick Johnstone 2005-07-07 08:35:31 UTC
Ok, so mine (I have two) look like the one on the right at this url:

ie they look just like the ones in picture 1 and picture 2 of the attachment to
this thread.

They are both 256MB and have this id on the side:
and they both fail in the same way.

From dmesg:
usb 1-2: new full speed USB device using address 2
SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices

but no device sda1 appears with the -11 kernel.


Comment 19 Pete Zaitcev 2005-07-07 17:59:09 UTC
Thanks for the info. Since we have a failing case of 256MB, I'll go with this:

Comment 20 Chris Van Hoof 2005-07-11 15:15:30 UTC
Fujifilm 256Mb, same issue with U1:

Comment 21 Andrew D. 2005-08-09 04:08:49 UTC
I dont know how related this is but I have a Transcend JetFlash 128MB MP3 player
which used to work fine as a USB memory stick. Now, when I try to mount it I get
the message "special device /dev/sda1 does not exist". The "dmesg" command shows
the following:
usb 7-2: new full speed USB device using address 14
usb-storage: probe of 7-2:1.0 failed with error -1
(the address increments by 1 with each plugging in of the device). I have the
following running when I do an "lsmod":

I am running kernel 2.6.9-11.ELsmp


Comment 22 Jason Baron 2005-08-09 14:42:34 UTC

a bit of a shot in the dark, but the U2 beta has *a lot* of fixes, and might be
worth trying: .thanks.


Comment 23 Dirk Gfroerer 2005-08-09 19:25:11 UTC
Thanks for the info. However the new kernel does not seem to fix this problem -
at least for me. The USB key is still not being recognized properly. The
messages in /var/log/messages seem to be the old ones (i.e. USB device detected,
mass storage driver loaded, reset after some time).

Comment 24 Pete Zaitcev 2005-08-10 23:44:02 UTC
No surprise here, sorry to say. I aimed for U2 with the fix, but the key
I acquired from CDW does NOT reproduce the problem. While I thought what
to do about this, development window for U2 closed.

Comment 25 Roderick Johnstone 2005-09-07 14:10:21 UTC
We rebuilt an FC 4 kernel (2.6.12-1.1398) and my Kingston Data Travellers work
fine with that whereas they fail with the EL4 -11 kernel. This is actually on
Scientific Linux 4.1.

Pete: If it would help I could loan you one of my Data Travellers thats shows
the fault. 


Comment 27 Pete Zaitcev 2005-11-01 00:18:22 UTC
Created attachment 120592 [details]
Candidate #1 - only clear halt after an error

It seems that no matter what we do, there's no way to make sure a device
won't fail if we clear toggles unconditionally. Exclusion lists get
unmanageable very quickly. So, the only soluion appears to be reactive,
not proactive, and clear halts upon an error only.

Comment 30 Pete Zaitcev 2005-12-09 05:40:51 UTC
This fix causes a regression for TEAC CD-224 (NOT the infamous CD-210).
See bug 175188. We may need to bump this into U4.

Comment 33 Red Hat Bugzilla 2006-03-07 19:08:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.