Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160307 - Garbage on the X-Display after logging out from GNOME
Summary: Garbage on the X-Display after logging out from GNOME
Keywords:
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On: libvgahw
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 10:52 UTC by Joachim Backes
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 18:10:49 UTC


Attachments (Terms of Use)

Description Joachim Backes 2005-06-14 10:52:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After upgrading from FC3 to FC4 having problems with X11: when leaving
a GNOME session with Gnome Menue->logout, then the display hardware is not
reset correctly: there remains a ugly pattern with red vertical stripes
on my LCD display so nothing more is readable.

Additionally, switching from the X Desktop to consoles with Ctl+Alt+F...
shows the same colored console windows (not black ones). 

My display: Nokia 800 Xa
My graphics card: Matrox G400 with 32 MB memory


Version-Release number of selected component (if applicable):
Fedora Core 4

How reproducible:
Always

Steps to Reproduce:
1.Upgrade from FC3 to FC3, start and leave X11
2.
3.
  

Actual Results:  Strange display contents

Expected Results:  a clean console (black).

Additional info:

Comment 1 Joachim Backes 2005-06-15 05:29:21 UTC
Hi,

the problem was solved when using the X11 module /usr/X11R6/lib/modules/libvgahw.a
from FC3 (1 reboot needed).

Comment 2 Mike A. Harris 2005-06-21 17:58:06 UTC
This seems to be a dupe of bug #153729 which seems to be caused by a
regression in libvgahw being tracked in bug #161242.  You might want to
CC yourself on these bugs also.

Please have a look at them, and their various dupes, etc. to see if you
believe it to be the same issue.

Thanks in advance.

Comment 3 Mike A. Harris 2005-06-23 18:10:49 UTC

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.