Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160295 - mc displays badly files >2GB
Summary: mc displays badly files >2GB
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
: 160729 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 07:59 UTC by Jan ONDREJ
Modified: 2013-07-02 23:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-10 10:26:29 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2005-06-14 07:59:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
mc has no large file support. Hangs when downloading (may be copying too)
a large file from FTP. Show 0 byes as size for >2GB files.


Version-Release number of selected component (if applicable):
mc-4.6.1a-0.9

How reproducible:
Always

Steps to Reproduce:
1. Try to show an large file (for example FC4-i386-DVD.iso) in mc.
2. You will see ?FC4-i386-DVD.iso as name and 0 bytes as size.

There is also a problem to download large files over FTP connection with mc.
mc hangs (segmentation fault). :(   

Additional info:

Comment 1 Leonard den Ottolander 2005-06-14 14:10:45 UTC
Typically an issue that you should report upstream
(http://savannah.gnu.org/projects/mc). Please check the upstream bug database to
make sure the issue hasn't been reported yet.

Please don't abuse the priority and severity tags. Use the link to read on how
to set them properly.

Closing UPSTREAM.


Comment 2 Jan ONDREJ 2005-06-15 13:39:21 UTC
OK, it is already reported in mc bugzilla, but I am also trying to fix this bug.

After removing of -D_FILE_OFFSET_BITS=64 from spec file anything works fine.
May be it is properly compiled only for x86_64 architecture?

It it still an UPSTREAM problem? :-)

And about severity tags. It has been reported with high priority, because it says:
  crashes - and also mc crashes after FTP connections to large files,
  loss of data - also files may be lossed after crash,
  severe memory - and segfault is a memory problem :-)


Comment 3 Jindrich Novy 2005-06-15 13:57:59 UTC
Hello Ondrej,

yes, this problem might be caused by some of my fixes to the upstream mc. I was
trying to prevent the truncations to 31/32 bits for file sizes in the .64bit
patch what was added recently. Thanks for reporting this problem upstream, but
I'm not quite sure at the moment it's actually affected. I need to investigate this.

Leonard, please don't close bugs without testing or thinking about cause of
them. It's better to let me to change status/close such bugs as I'm aware of the
changes I added downstream.

Comment 4 Jindrich Novy 2005-06-16 12:27:15 UTC
Ondrej, the problem is finally in the upstream code as I built completely
unpatched FC4 mc where this problem occurs, but the unpatched latest devel mc
works just fine. I'll release mc update for FC4 to fix this.

Comment 5 Jindrich Novy 2005-06-17 07:18:23 UTC
*** Bug 160729 has been marked as a duplicate of this bug. ***

Comment 6 Jindrich Novy 2005-06-17 07:19:38 UTC
Fix confirmed by Jan, update is coming soon.

Comment 7 Leonard den Ottolander 2005-07-03 13:07:07 UTC
Wrt comment #2 and comment #3: My mistake. I'll be more careful in closing bugs
in the future. :)


Comment 8 Jindrich Novy 2005-11-10 10:26:29 UTC
Should be fixed by former updates now.


Note You need to log in before you can comment on or make changes to this bug.