Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1602939 - System freeze while attempting to copy large file
Summary: System freeze while attempting to copy large file
Keywords:
Status: CLOSED DUPLICATE of bug 1598462
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-18 20:48 UTC by Nick Judd
Modified: 2018-07-20 16:56 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-20 16:56:32 UTC


Attachments (Terms of Use)

Description Nick Judd 2018-07-18 20:48:48 UTC
DESCRIPTION: 

Attempt to copy a large file from an external HDD to a location in my /home partition results in a system freeze. The system freezes not long after the amount written to disk begins to exceed the 8GB physical RAM on this machine, but it's a different amount each time (between 7.7 and ~15GB).

Using Nautilus to drag-and-drop the system hangs immediately. Opening a Terminal window and using cp, it takes longer, but it will eventually hang.

I also tried piping tar | pv and using pv to limit transfer speed on the theory that perhaps this was a memory/cache issue. As I have ~8GB swap, I believe I can rule this out.

VERSION INFORMATION: Fedora 28 (kernel 4.17.6-200.fc28.x86_64)

HOW REPRODUCIBLE:

On my machine, any file > 7 GB has a high probability of reproducing this behavior. Any file > 15 GB has a near certainty of reproducing this behavior.

STEPS TO REPRODUCE:

See above --- I believe asking Fedora to handle any IO stream of sufficient size from one volume to another will cause this behavior.

ACTUAL RESULTS:

Keyboard and mouse unresponsive
Screen hang
File IO stops
It appears the system is completely frozen.

EXPECTED RESULTS:

File copied from one location to another without incident

ADDITIONAL INFO:

This is a laptop with Windows 10 on the primary SSD. F28 has a second SSD all to itself using Fedora's default partition setup (LVM, the home directory is 400+ gb with 350+ gb free). Not sure it matters, but the SSD is NVME (pcie 3x4).

The system is running an Intel core i5-8250 CPU with 8 GB RAM.

I am trying to copy from an external HDD formatted NTFS. This whole situation is a little boggling to me because I managed to get the files ON to the HDD from another, older laptop running F27, a few weeks ago.

POSSIBLY RELATED:

Another user on ask.fedora reports a similar problem: 
https://ask.fedoraproject.org/en/question/124188/fedora-28-system-freeze-while-copying-large-file/

I suspect this existing bug in Bugzilla may be related:

https://bugzilla.redhat.com/show_bug.cgi?id=1598462

Comment 1 Jeremy Cline 2018-07-19 13:21:21 UTC
Hi Nick,

Thanks for the report. As you've noted, it's quite likely you're experiencing #1598462. Can you test 4.17.7 in updates-testing and see if that fixes this? If so, we can close this as a duplicate.

Comment 2 Nick Judd 2018-07-20 16:56:32 UTC
Cannot reproduce this issue under 4.17.7, pretty sure this was a duplicate of #1598462 and is now resolved.

*** This bug has been marked as a duplicate of bug 1598462 ***


Note You need to log in before you can comment on or make changes to this bug.