Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1602912 - [DOCS] Content-Type header for patching a buildConfig is incorrect
Summary: [DOCS] Content-Type header for patching a buildConfig is incorrect
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Kathryn Alexander
QA Contact: Wenjing Zheng
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-18 19:45 UTC by Eric Jones
Modified: 2018-07-24 12:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-24 12:27:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eric Jones 2018-07-18 19:45:09 UTC
Document URL: 
https://docs.openshift.com/container-platform/3.7/rest_api/oapi/v1.BuildConfig.html#Patch-oapi-v1-namespaces-namespace-buildconfigs-name

Section Number and Name: 
REST API Reference
/oapi/v1
v1.BuildConfig
Patch a BuildConfig in a namespace

Describe the issue: 
The Content-Type header listed here is incorrect (at least in 3.7 and I believe moving forward).

I know that some portions of the docs (especially those dealing with the API) are sometimes dynamically generated based on a swagger endpoint, but looking at the github repo that didn't seem to be the case (Happy to be the wrong on this).

Suggestions for improvement: 
Correct the Content-Type header from application/json-patch+json to application/merge-patch+json

Additional information: 
I have already fixed this in a PR that is waiting to be approved/accepted:
https://github.com/openshift/openshift-docs/pull/10885

Comment 2 Kathryn Alexander 2018-07-19 01:23:50 UTC
@Wenjing Zheng, here's the PR: https://github.com/openshift/openshift-docs/pull/10885

Will you PTAL? And does someone know what versions this change is valid in?

Comment 4 Kathryn Alexander 2018-07-24 12:27:32 UTC
@Wenjing Zheng, thank you for confirming that both methods work. Since they do, I'm closing this issue as not a bug.


Note You need to log in before you can comment on or make changes to this bug.