Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160291 - kernels source doesn't get created when kernel is installed
Summary: kernels source doesn't get created when kernel is installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL: http://forums.fedoraforum.org/showthr...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 07:45 UTC by Marc Wiriadisastra
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 16:56:56 UTC


Attachments (Terms of Use)

Description Marc Wiriadisastra 2005-06-14 07:45:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I erased the kernel using rpm -e --nodeps kernel-`uname -r` It deleted it properly.  It then created the source files. I then re-installed the kernel using yum -y install kernel.i686 and it failed to create the source directories.  Leaving me with symoblic links that don't go anywhere.

Kernel source was not installed.

It was done using an upgrade not a fresh install.

Version-Release number of selected component (if applicable):
2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1.rpm -e --nodeps kernel-`uname -r`
2.cd /usr/src
3.ls
4. kernels folder
5. mv kernels to /root to verify
6. yum -y install kernel.i686
7. installed correctly no kernels folder

  

Actual Results:  No kernels folder was created on kernel install however on removal kernels folder was created.

Expected Results:  The other way around.  The kernels folder with source should be created on install.
On removal it should remove the kernels folder or the source within it not create it.

Additional info:

It was an upgrade not a fresh install.  It may vary if its a complete fresh install.

Comment 1 Mike A. Harris 2005-06-17 16:56:56 UTC
This is not a bug in xorg-x11.




Note You need to log in before you can comment on or make changes to this bug.