Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1602869 - file /usr/lib from install of python2-atomicwrites-1.1.5-11.fc29.noarch conflicts with file from package filesystem-3.9-2.fc29.i686
Summary: file /usr/lib from install of python2-atomicwrites-1.1.5-11.fc29.noarch confl...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-atomicwrites
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michele Baldessari
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1602749 1607125 1607126
TreeView+ depends on / blocked
 
Reported: 2018-07-18 16:47 UTC by Ankur Sinha (FranciscoD)
Modified: 2018-07-31 17:19 UTC (History)
4 users (show)

Fixed In Version: python2-atomicwrites-1.1.5-12.fc29.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1607125 1607126 (view as bug list)
Environment:
Last Closed: 2018-07-31 17:19:17 UTC


Attachments (Terms of Use)

Description Ankur Sinha (FranciscoD) 2018-07-18 16:47:05 UTC
Description of problem:
I'm getting this error while trying to update a package.

file /usr/lib from install of python2-atomicwrites-1.1.5-11.fc29.noarch conflicts with file from package filesystem-3.9-2.fc29.i686



Version-Release number of selected component (if applicable):
python2-atomicwrites-1.1.5-11.fc29.noarch

Comment 1 Jonathan Underwood 2018-07-18 16:49:41 UTC
Also breaks building of python-lz4.

Comment 2 Michele Baldessari 2018-07-18 17:17:12 UTC
Thanks for the report. I think the automatic mass rebuild broke things for 
python2-atomicwrites-1.1.5-11.fc29.noarch.rpm which has these files:
...
/usr
/usr/lib
/usr/lib/python2.7
/usr/lib/python2.7/site-packages
/usr/lib/python2.7/site-packages/atomicwrites
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/atomicwrites/__init__.py
/usr/lib/python2.7/site-packages/atomicwrites/__init__.pyc
/usr/lib/python2.7/site-packages/atomicwrites/__init__.pyo
/usr/lib/python3.7
/usr/lib/python3.7/site-packages
/usr/lib/python3.7/site-packages/atomicwrites
/usr/lib/python3.7/site-packages/atomicwrites-1.1.5-py3.7.egg-info
/usr/lib/python3.7/site-packages/atomicwrites-1.1.5-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/atomicwrites-1.1.5-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/atomicwrites-1.1.5-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/atomicwrites-1.1.5-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/atomicwrites/__init__.py
/usr/lib/python3.7/site-packages/atomicwrites/__pycache__
/usr/lib/python3.7/site-packages/atomicwrites/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/atomicwrites/__pycache__/__init__.cpython-37.pyc
/usr/share
/usr/share/doc/python2-atomicwrites
/usr/share/doc/python2-atomicwrites/LICENSE
/usr/share/doc/python2-atomicwrites/README.rst
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/atomicwrites.1.gz




python2-atomicwrites-1.1.5-12.fc29.noarch.rpm has the correct files:
/usr/lib/python2.7/site-packages/atomicwrites
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/atomicwrites-1.1.5-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/atomicwrites/__init__.py
/usr/lib/python2.7/site-packages/atomicwrites/__init__.pyc
/usr/lib/python2.7/site-packages/atomicwrites/__init__.pyo
/usr/share/doc/python2-atomicwrites
/usr/share/doc/python2-atomicwrites/LICENSE
/usr/share/doc/python2-atomicwrites/README.rst

Comment 3 Ankur Sinha (FranciscoD) 2018-07-18 18:10:12 UTC
I guess we need to wait for a new repo-compose then. My builds are still failing.

Comment 4 Raphael Groner 2018-07-20 01:38:05 UTC
Some more packages in koschei's list of F27 affected by this issue:
psi-plus
enki
lumina-desktop
python-qutepart
qt-virt-manager

Comment 5 Michele Baldessari 2018-07-31 17:19:17 UTC
I guess by now the repo-compose has run and things are okay in F29 land. If not, feel free to reopen. Thanks!


Note You need to log in before you can comment on or make changes to this bug.