Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1602818 - Report based on Chargeback for project fails with ERROR -- : [TypeError]: no implicit conversion from nil to integer Method:[block in method_missing]
Summary: Report based on Chargeback for project fails with ERROR -- : [TypeError]: no ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Libor Pichler
QA Contact: juwatts
URL:
Whiteboard:
Depends On:
Blocks: 1613295
TreeView+ depends on / blocked
 
Reported: 2018-07-18 14:58 UTC by Niladri Roy
Modified: 2019-02-11 14:18 UTC (History)
11 users (show)

Fixed In Version: 5.10.0.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1613295 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:18:29 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Niladri Roy 2018-07-18 14:58:10 UTC
Description of problem:
Custom report based on "Chargeback for Project" fails when it is run below is the error

ERROR -- : [TypeError]: no implicit conversion from nil to integer  Method:[block in method_missing]

Version-Release number of selected component (if applicable):
5.9.3.4

How reproducible:
Everytime at Cu environment

Steps to Reproduce:
1.
2.
3.

Actual results:
Report fails everytime

Expected results:
Report should run successfully


Additional info:
Report had ran successfully before, currently fails to run since last 1 week

Comment 11 juwatts 2018-10-25 14:29:58 UTC
Verified custom report based on "Chargeback for Project" was created successfully and no TypeError was found in the logs. 

Build: 5.10.0.19.20181009184346_1c8bf5d


Note You need to log in before you can comment on or make changes to this bug.