Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160262 - Release notes not showing in installer
Summary: Release notes not showing in installer
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-13 21:55 UTC by Brian Wheeler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-06-17 14:49:48 UTC

Attachments (Terms of Use)
Anaconda Log (deleted)
2005-06-16 20:45 UTC, Brian Wheeler
no flags Details

Description Brian Wheeler 2005-06-13 21:55:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I tried hitting the 'release notes' during install but only a blank window appeared.  This was over an FTP installation.  Installation proceeded normally.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:

Additional info:

Comment 1 Chris Lumens 2005-06-14 13:50:58 UTC
What language are you using for installation?  Does the directory you're
installing from have any RELEASE-NOTES* files?

Comment 2 Brian Wheeler 2005-06-14 14:08:43 UTC
I'm using english & installing from and there's a
RELEASE-NOTES file present.

I tried the upgrade on another machine this morning with the same settings and
got the same results.

Doing an upgrade via http (just replace ftp: with http: above) works as expected.

There are no error messages on the other text consoles.

A file with the current time named "/tmp/RELEASE-NOTES-en_US.UTF-8.html" is on
the installation root, but it is empty.

Comment 3 Jeremy Katz 2005-06-16 20:09:04 UTC
Can you grab /tmp/anaconda.log and attach it here?

Comment 4 Brian Wheeler 2005-06-16 20:36:46 UTC
There doesn't seem to be anything about the release notes in here, but I've
attached it anyway.

I'm booting off of boot.iso in case that makes any difference...

Comment 5 Chris Lumens 2005-06-16 20:43:55 UTC
Looking into a bug in how we're handling urlgrabber FTP return values or a bug
in urlgrabber itself.  It's trying to get the first possibility for a
RELEASE-NOTES, somehow ending up with a 0-length file, and interpreting that as
success so no other possibilities are tried.  Hence, the blank window.

Comment 6 Brian Wheeler 2005-06-16 20:45:24 UTC
Created attachment 115574 [details]
Anaconda Log 

I checked the release notes window several times...but they were empty and it
didn't make a difference in the log.

Comment 7 Chris Lumens 2005-06-17 14:49:48 UTC
Argh, the problem here is that we're not guaranteed to get an exception if we
try to pull down a file that doesn't exist using FTP.  In some cases, urllib
doesn't know what to do and gives us back an empty file instead.  Fixed on rawhide.

Note You need to log in before you can comment on or make changes to this bug.