Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160261 - Installer shows bogus 'remaing time' numbers
Summary: Installer shows bogus 'remaing time' numbers
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-13 21:53 UTC by Brian Wheeler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-16 17:30:52 UTC


Attachments (Terms of Use)

Description Brian Wheeler 2005-06-13 21:53:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When doing a system update, the installer said there were "1170 minutes" minutes remaining.  It did count down to 0 eventually, and the installer didn't take any longer than previous updates.  The install was over FTP via a fast link.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
I've not tried to reproduce it since this happened on my employer's workstation.

Additional info:

Comment 1 Chris Lumens 2005-06-16 17:30:52 UTC
Do you remember if the time started out as something ridiculous but then came
back down into a more reasonable number?  Did it spike up to 1170 sometime in
the middle?

The time remaining algorithm is based on the amount of time taken to get all
packages that have already been installed.  I believe this amount of time should
be getting adjusted throughout the course of the installation.  The first
estimate is going to be heavily influenced by any temporary network congestion
or slowdown that may occur right at the beginning.  However the adjustment
process should eventually bring that initial pessimistic estimate back down to
something more reasonable.

Closing for now, but feel free to reopen if you continue seeing absurd numbers.

Comment 2 Brian Wheeler 2005-06-16 18:01:12 UTC
It started out reasonably for several packages then jumped up in one or two big
steps to 1170.  It was counting down by 5 minutes after every couple of packages
until it reached 0 (and thus the end of the package list).  

So it was adjusting, but it was way out of wack which was kind of surprising,
especially since I'm connected via a 100MB/s link to the FTP site that I
installed from and there wasn't any noticable time issues compared to the
installations of RedHat based distros I've done this way in the past.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.