Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160255 - lvcreate fails
Summary: lvcreate fails
Keywords:
Status: CLOSED DUPLICATE of bug 147358
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
: 160423 160714 161226 162812 163605 164735 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-13 21:04 UTC by Raymond Bennett
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-03 17:54:09 UTC


Attachments (Terms of Use)
Anaconda Crash Dump (deleted)
2005-06-13 21:06 UTC, Raymond Bennett
no flags Details

Description Raymond Bennett 2005-06-13 21:04:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; WOW64; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50215)

Description of problem:
When I was trying to install x86_64 from DVD, the system reported an internal error and asked me to file a bug report. This was an on HP xw9300 Workstation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create DVD from FC4 release
2. Attempt to install on xw9300 using "linux text" (as another issue occurs with graphical mode)
3. System bugchecks
  

Additional info:

Comment 1 Raymond Bennett 2005-06-13 21:06:35 UTC
Created attachment 115374 [details]
Anaconda Crash Dump

Comment 2 Chris Lumens 2005-06-14 01:51:20 UTC
What is your initial partitioning?  Are you telling it to automatically or
manually partition?  Do you choose to save existing partitions or delete them to
make room?  Is this a dual-boot setup, possibly with another Linux installation?

Comment 3 Raymond Bennett 2005-06-14 05:49:13 UTC
Initially everything was partitioned as one big drive for a windows install. 
There are 2 physical drives, and I had windows installed on the first. When 
installing fc4, I chose to automatically partition and remove all existing 
partitions.

Comment 4 Bill Rees 2005-06-29 01:44:46 UTC
I too had this error crop up.  My setup is an Amd athlon system with one disk at
/dev/hdc holding 200GB.  This error occurred right after I selected packages to
install.

I selected automatic partitioning which created one single logical volume.
I was in text mode setup since the graphical one failed to get past the X
initialization sequence.


Comment 5 Bill Rees 2005-06-29 01:49:08 UTC
An additional couple of settings comments.

The disk already had one partition of size 133GB on it as hdc2 and
there was a partition 1, /dev/hdc1, boot partition 100MB large.
The error message was exactly the same as the earlier attachment.


Comment 6 Bill Rees 2005-06-29 21:39:00 UTC
Well what do you know.  Moving the disk off of the 
secondary ide channel where it was /dev/hdc and
placing it onto the primary ide channel where it
is named /dev/hda, fixed the problem.

Comment 7 Gerwin Krist 2005-07-29 09:07:05 UTC
*** Bug 160714 has been marked as a duplicate of this bug. ***

Comment 8 Gerwin Krist 2005-07-29 09:08:09 UTC
*** Bug 161226 has been marked as a duplicate of this bug. ***

Comment 9 Gerwin Krist 2005-07-29 09:09:56 UTC
*** Bug 163605 has been marked as a duplicate of this bug. ***

Comment 10 Gerwin Krist 2005-07-29 09:11:10 UTC
*** Bug 162812 has been marked as a duplicate of this bug. ***

Comment 11 Gerwin Krist 2005-07-31 11:34:41 UTC
*** Bug 160423 has been marked as a duplicate of this bug. ***

Comment 12 Gerwin Krist 2005-07-31 11:36:32 UTC
*** Bug 164735 has been marked as a duplicate of this bug. ***

Comment 13 chris siegler 2005-07-31 15:54:40 UTC
(In reply to comment #2)
> What is your initial partitioning?  Are you telling it to automatically or
> manually partition?  Do you choose to save existing partitions or delete them to
> make room?  Is this a dual-boot setup, possibly with another Linux installation?

I got this same error and already filed a duplicate bug.

In my case, I used automatic partitioning and told it to delete all partitions
(including NTFS). It's not a dual boot setup.



Comment 14 Eric Herman 2005-08-01 12:29:16 UTC
I have successfully run this hardware config on RH9, FC1, FC2, & FC3. However,
this time I changed my current partitioning scheme. However, I have also done
that on many of the previous upgrades with no problem.

I run two 200GB Maxtor ATA133 drives (each on its own cable - secondary shared
with DVD drive) in a RAID1 mode on a P4 1.3GHz and 512MB RAMBUS memory (Gigabyte
MB). It is entirely a FC4 server (no other OS's). I manually partitioned my RAID
config which is set to ~6GB at /; ~512MB Swap; ~180GB /home.

I ended up rerunning the DVD setup and added only the bare minimum and it
worked. Still not too pleased with the stability of the installer.

Comment 15 Adam Duckworth 2005-09-02 15:46:22 UTC
I have also received a similar area when beginning the actual install. 

SystemError: pvcreate failed for <fsset.PartitionDevice instance at 0xb7b3690c>

Selected Automatic partitioning during setup, deleting all existing partitions 
and creating a single 13 GB partition. This occurred on a Gateway PIII

Comment 16 Gregory Maxwell 2005-09-07 15:42:27 UTC
I ran into this same failure mode on a i686 I was installing FC4 on for a
friend. Got around it by manually partitioning and not using LVM. After the
install was complete I noticed that any disk access was PAINFULLY slow, for
example logging in from a VT took about 4 minutes.  Hdparm looked okay and a
hdparm -t gave about 25MB/sec, ... slow for the not that old 40g drive that was
in the box.  Since they had a 200gb drive they wanted to use as well, I thought
I would try installing on that on a hunch that the slowness might be due to a
failing disk.  Install worked fine on the new disk, including LVM, and the
performance after the install was great.

So, perhaps there is some timeout which is too short as a part of the lvcreate
and in my case the failing disk was triggering it?  ... In any case.. just
another data point.

Comment 17 Jeremy Katz 2005-10-03 17:54:09 UTC

*** This bug has been marked as a duplicate of 147358 ***


Note You need to log in before you can comment on or make changes to this bug.