Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1602267 - HE cleanup didn't work and re-deploy failed.
Summary: HE cleanup didn't work and re-deploy failed.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 2.2.22
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.3.1
: ---
Assignee: Ido Rosenzwig
QA Contact: Liran Rotenberg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-18 06:10 UTC by Milan Kerslager
Modified: 2019-02-12 14:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 14:46:04 UTC
oVirt Team: Integration
rule-engine: ovirt-4.3+


Attachments (Terms of Use)
log from failed re-run of the --deploy (deleted)
2018-07-18 06:10 UTC, Milan Kerslager
no flags Details

Description Milan Kerslager 2018-07-18 06:10:23 UTC
Created attachment 1459643 [details]
log from failed re-run of the --deploy

Description of problem:
next run (start over) hosted-engine --deploy failed

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.2.22-1.el7.noarch
ovirt-hosted-engine-setup-2.2.23-1.el7.noarch

How reproducible:
I run deploy, but it failed. Even I deleted bridge (see bug #1602250) and run ovirt-hosted-engine-cleanup, at the next run the script fails.

Actual results:
[ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "msg": "network default not found"}
[ ERROR ] Failed to execute stage 'Closing up': Failed executing ansible-playbook


Expected results:
able to run again

Comment 1 Sandro Bonazzola 2018-09-21 07:04:18 UTC
Not identified as blocker for 4.2.7, moving to 4.2.8

Comment 2 Randy Martinez 2019-01-11 01:11:54 UTC
The ovirt bridge and virsh default net are 2 different things. After deleting the bridge, you'll need to have a default virsh net for the deployment to succeed. 

I would check that there's no default network defined in virsh.

# virsh net-list

 Name                 State      Autostart     Persistent
----------------------------------------------------------

If not, go ahead and recreate the default virsh net:

# virsh net-define /usr/share/libvirt/networks/default.xml
Network default defined from /usr/share/libvirt/networks/default.xml

# virsh net-autostart default
Network default marked as autostarted

# virsh net-start default
Network default started

Then retry the deploy. This should resolve your issue: "[ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "msg": "network default not found"}".

Comment 3 Sandro Bonazzola 2019-01-21 08:28:24 UTC
re-targeting to 4.3.1 since this BZ has not been proposed as blocker for 4.3.0.
If you think this bug should block 4.3.0 please re-target and set blocker flag.

Comment 4 Ido Rosenzwig 2019-02-12 14:46:04 UTC
The bug is not reproducible anymore. Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.