Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1602250 - if hosted-engine fails, libvirt bridge is not removed
Summary: if hosted-engine fails, libvirt bridge is not removed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 2.2.22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
: ---
Assignee: Ido Rosenzwig
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-18 05:06 UTC by Milan Kerslager
Modified: 2019-01-11 01:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 07:22:26 UTC
oVirt Team: Network


Attachments (Terms of Use)

Description Milan Kerslager 2018-07-18 05:06:04 UTC
Description of problem:
When hosted-engine --deploy fails, it should remove bridge it created.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.2.22.1-1.el7.noarch

Actual results:
virsh net-list shows default persistent network
virbr0 and virbr0-nic are there

Expected results:
Script runs these commands (not sure if it is sufficient):
virsh net-destroy default
virsh net-undefine default

Comment 1 Ido Rosenzwig 2018-07-18 07:22:26 UTC
This is by design.

We don't remove the bridges for couple of reasons:
1. If the setup has failed, you probably want to start it again and those bridges are needed.
2. Removing these network devices can cause unexpected issues.

If you would like to use your machine for other purposes, it is recommended to reinstall it.

Comment 2 Randy Martinez 2019-01-11 01:07:54 UTC
I would check that there's in fact no default network defined in virsh.

# virsh net-list

 Name                 State      Autostart     Persistent
----------------------------------------------------------

If not, go ahead and recreate the default virsh net:

# virsh net-define /usr/share/libvirt/networks/default.xml
Network default defined from /usr/share/libvirt/networks/default.xml

# virsh net-autostart default
Network default marked as autostarted

# virsh net-start default
Network default started

Then retry the deploy.


Note You need to log in before you can comment on or make changes to this bug.