Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160223 - [RHEL4-U2] diskdumputils - swap partition support
Summary: [RHEL4-U2] diskdumputils - swap partition support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Akira Imamura
QA Contact:
URL:
Whiteboard: kernel
Depends On: 156010
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-06-13 16:23 UTC by Yuuichi Nagahama
Modified: 2010-10-22 03:04 UTC (History)
6 users (show)

Fixed In Version: RHEA-2005-578
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 11:28:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2005:578 qe-ready SHIPPED_LIVE diskdumputils enhancement update 2005-10-05 04:00:00 UTC

Description Yuuichi Nagahama 2005-06-13 16:23:12 UTC
Description of new feature:
New feature to support swap partition as dump device.
Kernel modification(FZ#156010) and diskdumputils modification
are needed for swap partition support of Diskdump.

Version-Release number of selected component (if applicable):
RHEL4-U2

Comment 3 Tatsuo Uchida 2005-06-20 21:37:45 UTC
I made a patch of rc.sysinit which adds a hook to call savecore before swapon.


Comment 5 Akira Imamura 2005-08-01 22:40:26 UTC
Tim,

The code has already been included in the latest diskdumputils (1.1.7). This 
feature is still working correctly. Could you change the status to "MODIFIED"?

Regards,
Akira

Comment 6 Dave Anderson 2005-08-12 14:52:00 UTC
This issue has already been addressed in the current RHEL4-U2 diskdumputils
package that is being tested via:
 
  RHEA-2005:578 - diskdumputils enhancement update

Because this BZ is has been removed from the MUSTFIX/CANFIX list for U2,
the errata above is "red" flagging this bugzilla.  Not only that, the
errata text description contains a paragraph explaining how to use this
particular feature.

What should be done about this?  Should all of the references to this
feature be removed from the errata, considering that the functionality
remains in both the diskdumputils user package and the kernel diskdump
code?

Please advise ASAP.
 

Comment 7 Tim Burke 2005-08-16 19:06:57 UTC
Changing state to modified as this is already in RHEL4 U2.

Comment 12 Eric Hagberg 2005-09-20 17:53:33 UTC
"/etc/init.d/diskdump swapsavecore" won't work for those who have
network-mounted /usr... it isn't there during rc.sysinit, and you've got calls
to /usr/sbin/diskdumpfmt and /usr/sbin/savecore in there.

Comment 13 Eric Hagberg 2005-09-21 17:11:40 UTC
Additionally, it doesn't appear likely that the use of a swap partition will
work properly, due to the architecture of swap and diskdump.

As it "works" now, I have to make sure that my swap partition hasn't got any
data swapped into it when a crash is done, or else I'll get:

CPU frozen: #0#2#3
CPU#1 is executing diskdump.
start dumping
<4>mptscsih: ioc0: Attempting host reset! (sc=db52b0a0)
<6>mptbase: Initiating ioc0 recovery
check dump partition...
<3>disk_dump: bad signature in block 1
<3>disk_dump: check partition failed.
<6>disk_dump: diskdump failed, fall back to trying netdump

And even if there's nothing in swap and I've set up diskdump to use a swap
partition (and the crash is dumped), when it comes back up, swap won't get
mounted again, as the partition doesn't have the swap-space signature on it any
longer.

It seems that this boils down to the fact that swap requires a signature on the
partition and diskdump also requires a signature (of some sort) and those are
different from each other.

Comment 14 Nobuhiro Tachino 2005-09-21 18:17:27 UTC
The swap support works on my machine. According to the above kernel message, the
kernel tries to check the signature of block #1. It means that the diskdump
module does not acknowledge your dump partition as a swap device. Please show
the output of the following command:

  diskdumpfmt -vc <your dump partition>

The command just checks the status of the specified device. If the dump
partition is formatted as a swap partition, it will display the following:

<device name>
  status     : swap device
  block size : ********
  note       : -

The following informations are helpful to solve the problem:

o /etc/sysconfig/diskdump
o /etc/fstab
o The output of /proc/diskdump
o /var/log/messages and /var/log/messages.*
o The output of dmesg
o The output of swapon -s

Thank you,

Comment 15 Eric Hagberg 2005-09-21 19:42:07 UTC
Looks like the README needs an update, not just to include the support for a
swap partition, but to make sure that you _don't_ run "/etc/init.d/diskdump
initialformat" if using a swap device... as that's what I was doing (following
directions) and it was failing because of it.

Skipping that step makes the diskdump to swap work fine.

Comment 18 Larry Troan 2005-09-30 17:40:45 UTC
Jay confirmed. In U2. Removing U3Proposed.

Comment 19 Red Hat Bugzilla 2005-10-05 11:28:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-578.html



Note You need to log in before you can comment on or make changes to this bug.