Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160219 - tux webserver causes kernel oops when encoutering a symlink
Summary: tux webserver causes kernel oops when encoutering a symlink
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-13 16:03 UTC by J. Nick Koston
Modified: 2015-01-04 22:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-27 05:32:07 UTC


Attachments (Terms of Use)
Resolve symlink panic (deleted)
2005-06-13 16:04 UTC, J. Nick Koston
no flags Details | Diff

Description J. Nick Koston 2005-06-13 16:03:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050523 CentOS/1.0.4-1.4.1.centos4 Firefox/1.0.4

Description of problem:
http://TUXWEBSERVER/SYMLINKEDFILE = oops

Version-Release number of selected component (if applicable):
2.6.11

How reproducible:
Always

Steps to Reproduce:
1. http://TUXWEBSERVER/SYMLINKEDFILE 
2.
3.
  

Additional info:

Comment 1 J. Nick Koston 2005-06-13 16:04:46 UTC
Created attachment 115354 [details]
Resolve symlink panic

Comment 2 Dave Jones 2005-06-24 02:01:04 UTC
I just fixed this (in a slightly different way) in FC4/rawhide.  Tomorrows
2.6.11-1.37_FC3 kernel will be the last 2.6.11 update for FC3, before I backport
the FC4 kernel (containing this fix) to FC3.

Hopefully I'll get a 2.6.12 kernel out for FC3 pretty soon.


Comment 3 Ingo Molnar 2005-06-24 11:57:39 UTC
thanks for the fix - i updated the upstream patches too, at
http://redhat.com/~mingo/TUX-patches/

Comment 4 Dave Jones 2005-07-15 18:08:07 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 5 Denis Saveliev 2005-11-30 02:06:35 UTC
I'm running FC4 and it seems that with 2.6.13-1.1532_FC4 still has this bug and
the latest kernel-2.6.11-1.1369_FC4 and kernel-2.6.14-1.1637_FC4 do not have TUX
support built in.



Note You need to log in before you can comment on or make changes to this bug.