Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160210 - Installer does not see adaptec 2010s controller
Summary: Installer does not see adaptec 2010s controller
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-13 14:44 UTC by David Bunt
Modified: 2015-01-04 22:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-18 14:40:21 UTC


Attachments (Terms of Use)

Description David Bunt 2005-06-13 14:44:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Description of problem:
During install, i2o module doesn't detect the Adaptec 2010s raid card.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1286_FC4.i686

How reproducible:
Always

Steps to Reproduce:
1. Put in cd 1
2. Boot machine
3. Run installer
  

Actual Results:  Installer asks me to select drivers because it couldn't find any hard drives. 

Expected Results:  Installer should have automatically detected the raid card and drives.

Additional info:

This 2010s controller is on a supermicro superserver 6023P-8R. Redhat 8,9,FC1 detects this array just fine using the dpt_i2o driver. FC2, FC3, FC4-test 3 doesn't. Trying to download and insmod i2o_block.ko manually at install doesn't work either. 

Output from /etc/sysconfig/hwconf on the working FC1 install:
-
class: HD
bus: SCSI
detached: 0
device: sda
driver: ignore
desc: "Adaptec RAID-5"
host: 0
id: 0
channel: 0
lun: 0
generic: sg0
-
class: RAID
bus: PCI
detached: 0
driver: dpt_i2o
desc: "Distributed Tech|SmartRAID V Controller"
vendorId: 1044
deviceId: a511
subVendorId: 1044
subDeviceId: c035
pciType: 1
pcibus:  6
pcidev:  1
pcifn:  0
-


Output from /proc/scsi/scsi from the working FC1 install:
-
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ADAPTEC  Model: RAID-5           Rev: 3B05
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: SUPER    Model: GEM318           Rev: 0
  Type:   Processor                        ANSI SCSI revision: 02
-

Output from /proc/scsi/dpt_i2o/0 from the working FC1 install:
-
Adaptec I2O RAID Driver Version: 2.4 Build 5

Vendor: Adaptec  Model: 2010S            FW:3B05
SCSI Host=scsi0  Control Node=/dev/dpti0  irq=72
        post fifo size  = 255
        reply fifo size = 255
        sg table size   = 56

Devices:
        ADAPTEC RAID-5           Rev: 3B05
        TID=525, (Channel=0, Target=0, Lun=0)  (online)

        SUPER   GEM318           Rev: 0
        TID=518, (Channel=0, Target=6, Lun=0)  (online)
-

Comment 1 David Bunt 2005-06-24 15:02:41 UTC
Just tried this with FC4 release. Results are a bit different. 
The installer still doesn't detect the adapter. I manually add the i2o_block
driver from the list. The installer then hangs at Checking for existing fedora
core installs at 0%.
Debug information shows:
block-osm:/dev/i2o/hda error: Failure communicating to device
end-request: I/O error dev i2o/hda
block-osm: still remaining chunks



Comment 2 Dave Jones 2005-07-15 21:33:46 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 3 David Bunt 2005-07-26 13:47:49 UTC
As this bug deals with new installations, the last comment doesn't apply to this
situation.

Comment 4 David Bunt 2005-08-16 15:49:29 UTC
Any progress with this bug?

Comment 5 Markus Lidel 2005-08-17 13:29:04 UTC
Hello,

could you load the i2o_block module manually by selecting it from the list?

Best regards,

Markus Lidel

Comment 6 David Bunt 2005-08-17 15:36:02 UTC
I can but the console reports a seek error and the installer hangs.



Comment 7 Markus Lidel 2005-08-17 16:23:07 UTC
Hello,

could you switch to the logging-console? And if yes, is there some error message?

Best regards,

Markus Lidel

Comment 8 David Bunt 2005-08-17 16:48:43 UTC
The logging-console is where it reports the drive seek error. 


Comment 9 Markus Lidel 2005-08-18 10:42:16 UTC
Hello,

is there no output from the I2O driver?

Something like: i2o: Checking for PCI I2O controllers...

Best regards,

Markus Lidel

Comment 10 David Bunt 2005-08-18 14:40:21 UTC
Yes, and I had pen and paper in hand to copy it down, but now all the sudden
things are working as expected now. 
I tried (note all these failed on 2 seperate identical servers before) 
FC3 disk 1 raid 1 fc1 previous install- worked
FC3 disk 1 raid 1 new array - worked
FC3 disk 1 raid 5 new array - worked
FC3 kickstart raid 5 new array - worked
FC4 disk 1 raid 5 new array - worked

I just don't get it.. Resolving ticket.


Note You need to log in before you can comment on or make changes to this bug.