Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1602092 - Cannot install package python2-ipaserver
Summary: Cannot install package python2-ipaserver
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-17 19:31 UTC by Lukas Slebodnik
Modified: 2018-07-26 13:04 UTC (History)
8 users (show)

Fixed In Version: freeipa-4.7.0-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-26 13:04:01 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2018-07-17 19:31:14 UTC
Description of problem:

It is not possible to install the package python2-ipaserver in rawhide
due to missing dependencies.

  sh# dnf install python2-ipaserver
  Last metadata expiration check: 0:02:37 ago on Tue Jul 17 19:15:24 2018.
  Error: 
   Problem: conflicting requests
    - nothing provides python2-pki >= 10.6.0-0.2 needed by python2-ipaserver-4.6.90.pre2-9.fc29.noarch

  sh# dnf repoquery --whatprovides python2-pki (which is a date of build pki-core-10.5.6-2.fc29)
  Last metadata expiration check: 0:06:58 ago on Tue Jul 17 19:15:24 2018.

Such situation in rawhide is since Thu, 22 Feb 2018 06:17:04 UTC (the first build in f29 buildroot). The package python2-pki is available just in f28.
  sh# dnf repoquery --whatprovides python2-pki
  Last metadata expiration check: 0:00:37 ago on Tue Jul 17 19:24:20 2018.
  python2-pki-0:10.6.0-1.fc28.noarch
  python2-pki-0:10.6.1-3.fc28.noarch


There are basically two ways how to solve it:
* move BZ to pki-core to provide python2 bindings (and also python3 bindings)
* stop buiding python2 packages for freeIPA in rawhide(fc29)

Version-Release number of selected component (if applicable):
python2-ipaserver-4.6.90.pre2-11.fc29.noarch

How reproducible:
Deterministic 

Steps to Reproduce:
1. dnf install -y python2-ipaserver

Actual results:
  sh# dnf install python2-ipaserver
  Last metadata expiration check: 0:02:37 ago on Tue Jul 17 19:15:24 2018.
  Error: 
   Problem: conflicting requests
    - nothing provides python2-pki >= 10.6.0-0.2 needed by python2-ipaserver-4.6.90.pre2-9.fc29.noarch

Expected results:
There are basically two ways how to solve it:
* move BZ to pki-core to provide python2 bindings (and also python3 bindings)
* stop buiding python2 packages for freeIPA in rawhide(fc29)

Comment 1 Rob Crittenden 2018-07-17 19:51:34 UTC
python2-ipaserver is going to be dropped.

python2-ipaclient is going to be kept for Fleet Commander until they can port to python 3.

There is going to be an upstream release Real Soon Now (TM) and this should be addressed at that point.

Comment 2 Christian Heimes 2018-07-18 13:45:02 UTC
Note: ipsilon is indirectly depending on python2-ipalib, too. See #1602430


Note You need to log in before you can comment on or make changes to this bug.