Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160193 - Possible ambiguities in Anaconda screens
Summary: Possible ambiguities in Anaconda screens
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-06-13 09:15 UTC by Leslie Katz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-27 21:12:32 UTC


Attachments (Terms of Use)

Description Leslie Katz 2005-06-13 09:15:51 UTC
Description of problem: A few of the Anaconda screens seem to me to contain
statements the language of which could be improved to avoid possible confusion.
They troubled me, a newcomer, during a recent installation and might trouble
others similarly placed.

One is the "Automatic Partitioning" screen, which invites a person to choose one
of three options, the first of which is to remove all Linux partitions on "this
system" and the second of which is to remove all partitions on "this system".
The reference to "this system" implies (at least to me) that the specified
partitions will be removed from ALL hard drives in one's computer, if there
should exist more than one. It would be better to invite a person to remove the
Linux or all partitions on the drive on which it is intended to install Linux.

The second is the "Boot Loader Configuration" screen, which says that the GRUB
boot loader will be installed on "/dev/hda". That won't be the case if the
person has only a SCSI drive or drives, nor will it necessarily be the case if a
person has more than one IDE drive.

The third is the "Advanced Boot Loader Configuration" screen. On that screen,
one is invited to install the Boot Loader "record" somewhere, as opposed to the
"boot loader" referred to on the preceding screen. I assume that the later
reference was intended to be to the boot loader, just like the earlier one.
Further, the two choices given suffer from the same problem as the statement on
the preceding screen.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: The things I've mentioned aren't technically "bugs", but I
don't know how else to raise them.

I was rather nervous during the installation on a second IDE drive bought
specifically for FC3, afraid that I might do something to cause problems with my
original drive. I imagine others would feel the same. The less ambiguity in the
screens, the less the nervousness.

Comment 1 David Cantrell 2006-01-27 21:12:32 UTC
Though it's been a while, these issues have been addressed in rawhide:

1)  The automatic partition layout screen was reworded to avoid ambiguity.  The
phrase 'selected drive' instead of 'this system' is used in the combo box
choices.  A list of available physical drives are presented below the combo box
allowing the user to only check the ones that anaconda should use for installation.

2)  The boot loader configuration screen references the correct device name,
either /dev/sda or /dev/hda (or others) depending on your system

3)  The boot loader record is the boot loader itself and where you want it
installed.  Most people prefer the MBR.  At one point anaconda supported lilo,
so I think this is leftover terminology.


Note You need to log in before you can comment on or make changes to this bug.