Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601917 - ValueError: PyCapsule_GetPointer called with incorrect name [NEEDINFO]
Summary: ValueError: PyCapsule_GetPointer called with incorrect name
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libarcus
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1387943 qt511 1602361 1603891 1604899 1606805 1606806
TreeView+ depends on / blocked
 
Reported: 2018-07-17 13:01 UTC by Miro Hrončok
Modified: 2018-11-12 09:57 UTC (History)
3 users (show)

Fixed In Version: libarcus-3.3.0-4.fc29, libarcus-3.5.1-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-12 09:57:20 UTC
mhroncok: needinfo? (rdieter)


Attachments (Terms of Use)

Description Miro Hrončok 2018-07-17 13:01:55 UTC
Description of problem:
Several of my python3 qt5 packages FTBFS with:

ValueError: PyCapsule_GetPointer called with incorrect name


Version-Release number of selected component (if applicable):
python3-qt5-5.11.2-1.fc29.x86_64
python3-qscintilla-qt5-2.10.7-1.fc29.x86_64
python3-arcus-3.3.0-2.fc29.x86_64

How reproducible: Easy


Steps to Reproduce:
1. install above mentioned packages
2. run python3
3. observe:

>>> import Arcus
>>> import PyQt5.Qsci 
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
RuntimeError: the PyQt5.QtCore module failed to register with the sip module
>>> import PyQt5.Qsci 
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ValueError: PyCapsule_GetPointer called with incorrect name

(new session)

>>> import PyQt5.QtCore
>>> import Arcus
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ValueError: PyCapsule_GetPointer called with incorrect name
>>> import PyQt5.Qsci 
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ValueError: PyCapsule_GetPointer called with incorrect name

Comment 1 Miro Hrončok 2018-07-25 09:54:06 UTC
Rebuilding the packages didn't help here.

Comment 2 Miro Hrončok 2018-08-12 20:50:58 UTC
Is there anything I can do to help fix this? My package is still requiring Python 3.6 because it cannot be rebuilt. I don't want to retire it.

Comment 3 Jan Kurik 2018-08-14 09:52:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 4 Rex Dieter 2018-08-14 19:40:10 UTC
I think this may be (partially?) fixed now, at least eric builds successfully when before it didn't.  I didn't do anything explicitly to fix it.

cura scratch build still fails though, so keeping this open.

Comment 5 Miro Hrončok 2018-08-14 21:44:17 UTC
Maybe I need to rebuild arcus first?

Comment 6 Miro Hrončok 2018-08-14 23:26:52 UTC
(In reply to Miro Hrončok from comment #5)
> Maybe I need to rebuild arcus first?

Didn't help.

Comment 7 Rex Dieter 2018-08-23 13:21:50 UTC
This probably warrants filing a bug/issue with PyQt and arcus upstreams at this point.

Comment 8 Rex Dieter 2018-08-23 13:23:25 UTC
https://riverbankcomputing.com/pipermail/pyqt/2018-June/040474.html

Hrm, I'll take a closer look

Comment 9 Miro Hrončok 2018-08-23 13:33:18 UTC
Yes, every googled thing I've managed to get indicated a packaging problem (removing everything and reinstalling fixed the issue mostly).

Comment 10 Rex Dieter 2018-08-23 13:38:12 UTC
And... taking a closer look I cannot reproduce this using the test builds @
https://copr.fedorainfracloud.org/coprs/rdieter/PyQt/builds/

so... may be a rawhide-only issue?

Comment 11 Rex Dieter 2018-08-23 14:00:18 UTC
OK, figured it out.

Latest PyQt5 versions include and use a private copy of sip module, named PyQt5.sip now.

Arcus is (still) using the old non-namspaced module named sip.

When I explicitly removed python3-sip, I get this error:

>>> import Arcus
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'sip'
>>> 

So, Arcus' python code needs some patching

In the meantime, I'll try to adjust sip packaging to make this clearer somehow.

Comment 12 Rex Dieter 2018-08-23 14:06:05 UTC
Reassigning to libarcus, that's where the fix needs to happen.

Comment 13 Rex Dieter 2018-08-23 14:39:49 UTC
I'll work on a pull request to implement that

Comment 15 Miro Hrončok 2018-08-23 15:14:23 UTC
The fix works. Thank you so much!

Comment 16 Rex Dieter 2018-08-28 19:13:11 UTC
FYI, submitted upstream issue on the topic
https://github.com/Ultimaker/libArcus/issues/76
to hopefully get it fixed properly so we won't have to carry patches downstream

Comment 17 Miro Hrončok 2018-08-28 21:07:22 UTC
Thanks fro bringing that upstream.

FYI your commit https://src.fedoraproject.org/rpms/libarcus/c/389686ab44edf78c8f1afa098c92f226d8b089b1 FTBFS. Please use pull requests to verify buildability of such changes.

Comment 18 Rex Dieter 2018-08-28 21:19:24 UTC
Strange, I tested it thoroughly with mock and local builds.

I'll take a closer look.

Comment 19 Miro Hrončok 2018-09-12 09:23:30 UTC
This is Fedora 29:

<mock-chroot> sh-4.4# rpm -q python3-arcus
python3-arcus-3.4.1-1.fc29.x86_64
<mock-chroot> sh-4.4# python3 -c 'import Arcus'
<mock-chroot> sh-4.4# echo $?
0


This is Fedora 30:

<mock-chroot> sh-4.4# rpm -q python3-arcus
python3-arcus-3.4.1-2.fc30.x86_64
<mock-chroot> sh-4.4# python3 -c 'import Arcus'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ModuleNotFoundError: No module named ' PyQt5'


This is f29 branch rebuilt for Fedora 30:

<mock-chroot> sh-4.4# rpm -q python3-arcus
python3-arcus-3.4.1-1.fc30.x86_64
<mock-chroot> sh-4.4# python3 -c 'import Arcus'
<mock-chroot> sh-4.4# echo $?
0


I guess the libArcus-3.4.1-sip_flags.patch introduced this, yet I fail to find where would the space go from.

Would you be able to help?

Comment 20 Miro Hrončok 2018-11-12 09:30:14 UTC
Next version does not suffer form this.

Thanks for the help.

Comment 21 Miro Hrončok 2018-11-12 09:49:27 UTC
Oh. So the reproducer no longer works, but I still get the same error.

Will try to rebase the patch.


Note You need to log in before you can comment on or make changes to this bug.