Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160187 - Build fails on x86_64 for FC3
Summary: Build fails on x86_64 for FC3
Keywords:
Status: CLOSED DUPLICATE of bug 160188
Alias: None
Product: Fedora
Classification: Fedora
Component: gnomesword
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael A. Peters
QA Contact: Fedora Extras Quality Assurance
URL: http://mpeters.us/fc_extras/gnomeswor...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-13 07:21 UTC by Michael A. Peters
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-13 11:00:12 UTC


Attachments (Terms of Use)

Description Michael A. Peters 2005-06-13 07:21:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The package fails to build on x86_64 for Fedora Core 3.
This looks like a different issue than the FC4/devel issue

g++ -O2 -g -pipe -m64 -ftemplate-depth-25 -o gnomesword2 about_gnomesword.o abou
t_modules.o about_sword.o bibletext.o bibletext_dialog.o bookmarks_menu.o bookma
rks_treeview.o cipher_key_dialog.o commentary.o commentary_dialog.o dialog.o dic
tlex.o dictlex_dialog.o display_info.o dummy.o fileselection.o find_dialog.o fon
t_dialog.o gbs.o gbs_dialog.o gnomesword.o gui.o hints.o html.o main_menu.o main
_window.o mod_mgr.o note_editor.o parallel_view.o parallel_dialog.o preferences_
cell_renderer.o preferences_dialog.o search_dialog.o search_sidebar.o session.o 
setup_druid.o sidebar.o sidebar_dialog.o splash.o studypad.o toolbar_nav.o tabbe
d_browser.o utilities.o -Wl,--export-dynamic -Wl,--export-dynamic -Wl,--export-d
ynamic  -L/usr/X11R6/lib64 -lgtkhtml-3.1 -lgnomeprintui-2-2 -lgnomeprint-2-2 -pt
hread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomecanvas-2 -lgnome-2 /usr/lib/lib
popt.so -lart_lgpl_2 -lpangoft2-1.0 -lbonobo-2 -lgconf-2 -lgnomevfs-2 -lbonobo-a
ctivation -lORBit-2 -lgthread-2.0 -lglade-2.0 -lgtk-x11-2.0 -lxml2 -lpthread -lg
dk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.
0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -L/usr/kerberos/lib -L/usr/kerberos/lib
64 -L/usr/lib -lsword -lcurl -ldl -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lre
solv -lidn -lssl -lcrypto -lz ../../src/main/libmain.a ../../src/editor/libedito
r.a ../../src/backend/libbackend.a
/usr/lib/libpopt.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[3]: *** [gnomesword2] Error 1
make[3]: Leaving directory `/usr/src/rpm/BUILD/gnomesword-2.1.2/src/gnome2'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/rpm/BUILD/gnomesword-2.1.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/rpm/BUILD/gnomesword-2.1.2'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.88749 (%build)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to build on x86_64 in fc3
2.
3.
  

Actual Results:  build fails

Expected Results:  pretty rpm

Additional info:

Comment 1 Michael A. Peters 2005-06-13 11:00:12 UTC

*** This bug has been marked as a duplicate of 160188 ***


Note You need to log in before you can comment on or make changes to this bug.