Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160186 - gnomesowrd - Fails to build on x86_64
Summary: gnomesowrd - Fails to build on x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnomesword
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael A. Peters
QA Contact: Fedora Extras Quality Assurance
URL: http://mpeters.us/fc_extras/gnomeswor...
Whiteboard:
Depends On:
Blocks: FE4Target-x86_64
TreeView+ depends on / blocked
 
Reported: 2005-06-13 07:14 UTC by Michael A. Peters
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.1.2-2.3.fc4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-15 22:58:11 UTC


Attachments (Terms of Use)

Description Michael A. Peters 2005-06-13 07:14:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
gnomesword fails to build  on x86_64 for fc4/development

In file included from ../../src/main/sword.h:29,
                 from display.cc:53:
/usr/include/glib-2.0/glib/gi18n.h:25:1: warning: "_" redefined
In file included from /usr/include/libgnome-2.0/libgnome/gnome-i18n.h:40,
                 from /usr/include/libgnome-2.0/libgnome/libgnome.h:30,
                 from /usr/include/libgnomeui-2.0/gnome.h:5,
                 from ../../src/gui/utilities.h:26,
                 from ../../src/main/display.hh:31,
                 from display.cc:49:
/usr/include/libbonobo-2.0/bonobo/bonobo-i18n.h:69:1: warning: this is the locat
ion of the previous definition
/usr/include/libintl.h:40: error: expected unqualified-id before 'const'
/usr/include/libintl.h:40: error: expected `)' before 'const'
/usr/include/libintl.h:40: error: expected initializer before 'const'
/usr/include/libintl.h:45: error: expected unqualified-id before 'const'
/usr/include/libintl.h:45: error: expected `)' before 'const'
/usr/include/libintl.h:45: error: expected initializer before 'const'
/usr/include/libintl.h:52: error: expected unqualified-id before 'const'
(etc.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to build on x86_64
2.
3.
  

Actual Results:  build fails

Expected Results:  build succeeds

Additional info:

Comment 1 Ignacio Vazquez-Abrams 2005-06-13 08:39:02 UTC
Oh my. This looks like a problem with either Core -devel packages or gnomesword
including too many headers.

Comment 2 Matthew MacLeod 2005-09-10 22:36:08 UTC
I've been seeing this on several distros for at least a year. I can't believe
it's not more widely reported/solved.

Comment 3 Michael A. Peters 2005-09-15 09:28:53 UTC
I have a src.rpm that *might* fix the problem.
I don't have an x86_64 machine to test the build on myself.

The new src.rpm is here:
http://mpeters.us/fc_extras/gnomesword-2.1.2-2.2.fc4.src.rpm

I would appreciate it if someone could test the src.rpm (preferably building
with mock, but not required) and let me know if the build works or not.

If it works, I'll commit the patch to cvs and request a build.

Comment 4 Michael A. Peters 2005-09-15 12:44:12 UTC
That src.rpm above didn't do it - but a minor change to it did.
Through build system, release pending.


Note You need to log in before you can comment on or make changes to this bug.