Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160184 - System fails to boot into single user mode
Summary: System fails to boot into single user mode
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Grubb
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-13 05:11 UTC by James Morris
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-13 21:09:45 UTC


Attachments (Terms of Use)

Description James Morris 2005-06-13 05:11:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When specifying single user mode via the grub kernel command line, the system boots instead into runlevel 3 (the default on my system).

This is on an FC4 minimal install, with some fc dev rpms installed and upgraded to latest rawhide as of Saturday.

Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. Specify single user mode at grub prompt, kernel command line '1' or 'single'
2.
3.
  

Actual Results:  System comes up in runlevel 3

Expected Results:  System comes up in runlevel 1

Additional info:

Excerpted boot log:

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.11-1.1381_FC5smp ro root=/dev/VolGroup00/LogVol00 console=t
ty1 console=ttyS0,115200 1 audit=0 selinux=0
   [Linux-bzImage, setup=0x1e00, size=0x17a203]
initrd /initrd-2.6.11-1.1381_FC5smp.img
   [Linux-initrd @ 0x37e36000, 0x1b9fc4 bytes]

Linux version 2.6.11-1.1381_FC5smp (bhcompile@tweety.build.redhat.com) (gcc version 4.0.0 20050606 (Red Hat 4.0.0-11)) #1 SMP Thu Ju
n 9 21:13:54 EDT 2005

....

Enabling swap space:  [  OK  ]
INIT: Entering runlevel: 1
Entering non-interactive startup
Calling the system activity data collector (sadc): 
Telling INIT to go to single useINIT: Sending processes the KILL signal
INIT: Entering runlevel: 

...

Comment 1 James Morris 2005-06-13 05:12:56 UTC
Last line of boot log should be:

INIT: Entering runlevel: 3


Comment 2 Bill Nottingham 2005-06-13 20:30:35 UTC
Assigning auditwards based on something James said on IRC. Please flip back if
something else is going on here.

Comment 3 Steve Grubb 2005-06-13 20:50:16 UTC
The audit daemon acts like any other daemon. It doesn't do anything special at
boot. It doesn't in anyway affect the runlevel as mentioned. It can take the
system to Single User mode if its out of logging space and its configured to do
so, but that's not the default config...nor is that the problem being reported.
This problem lies somewhere else.

Comment 4 Bill Nottingham 2005-06-13 21:09:45 UTC
Can't reproduce this here on a minimal install (targeted policy) upgraded to
rawhide.


Note You need to log in before you can comment on or make changes to this bug.