Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601816 - [3.9] Fail to register node during installation
Summary: [3.9] Fail to register node during installation
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-17 09:51 UTC by Gaoyun Pei
Modified: 2018-07-18 03:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 03:05:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gaoyun Pei 2018-07-17 09:51:38 UTC
Description of problem:
Installation of ocp-3.9.33 on openstack failed at TASK [openshift_manage_node : Wait for Node Registration] 

TASK [openshift_manage_node : Wait for Node Registration] **************************************************************************************************************
...
FAILED - RETRYING: Wait for Node Registration (1 retries left).
fatal: [dhcp-89-127.sjc.redhat.com -> dhcp-89-127.sjc.redhat.com]: FAILED! => {"attempts": 50, "changed": false, "failed": true, "results": {"cmd": "/usr/local/bin/oc get node qe-gpei-39stage4master-etcd-1 -o json -n default", "results": [{}], "returncode": 0, "stderr": "Error from server (NotFound): nodes \"qe-gpei-39stage4master-etcd-1\" not found\n", "stdout": ""}, "state": "list"}
fatal: [dhcp-89-148.sjc.redhat.com -> dhcp-89-127.sjc.redhat.com]: FAILED! => {"attempts": 50, "changed": false, "failed": true, "results": {"cmd": "/usr/local/bin/oc get node qe-gpei-39stage4node-registry-router-1 -o json -n default", "results": [{}], "returncode": 0, "stderr": "Error from server (NotFound): nodes \"qe-gpei-39stage4node-registry-router-1\" not found\n", "stdout": ""}, "state": "list"}



Error logs found in atomic-openshift-node service:
Jul 17 09:37:16 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: E0717 09:37:16.695486   26262 kubelet_node_status.go:106] Unable to register node "qe-gpei_39stage4master-etcd-1" with API server: nodes "qe-gpei_39stage4master-etcd-1" is forbidden: node "qe-gpei-39stage4master-etcd-1" cannot modify node "qe-gpei_39stage4master-etcd-1"
Jul 17 09:37:17 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: I0717 09:37:17.068187   26262 kubelet.go:1942] SyncLoop (housekeeping)
Jul 17 09:37:17 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: I0717 09:37:17.407540   26262 generic.go:183] GenericPLEG: Relisting
Jul 17 09:37:17 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: I0717 09:37:17.636059   26262 eviction_manager.go:221] eviction manager: synchronize housekeeping
Jul 17 09:37:17 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: E0717 09:37:17.637422   26262 eviction_manager.go:238] eviction manager: unexpected err: failed to get node info: node "qe-gpei_39stage4master-etcd-1" not found
Jul 17 09:37:17 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: W0717 09:37:17.675736   26262 cni.go:171] Unable to update cni config: No networks found in /etc/cni/net.d
Jul 17 09:37:17 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: I0717 09:37:17.677179   26262 kubelet.go:2129] Container runtime status: Runtime Conditions: RuntimeReady=true reason: message:, NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized
Jul 17 09:37:17 qe-gpei-39stage4master-etcd-1 atomic-openshift-node[26235]: E0717 09:37:17.678063   26262 kubelet.go:2132] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized



Couldn't reproduce this issue on AWS with the same version 3.9.33 openshift-ansible and ose/node images.


Version-Release number of selected component (if applicable):
Installer:
openshift-ansible-3.9.33-1.git.56.19ba16e.el7.noarch

[root@qe-gpei-39stage4node-registry-router-1 ~]# docker images
REPOSITORY                                                TAG                 IMAGE ID            CREATED             SIZE
registry.access.stage.redhat.com/openshift3/openvswitch   v3.9.33             9a6123739844        5 days ago          1.49 GB
registry.access.stage.redhat.com/openshift3/node          v3.9.33             0c0b8e980424        5 days ago          1.47 GB
[root@qe-gpei-39stage4node-registry-router-1 ~]# docker run --entrypoint rpm registry.access.stage.redhat.com/openshift3/node:v3.9.33 -qa |grep atomic-openshift
atomic-openshift-3.9.33-1.git.0.c35d02e.el7.x86_64
atomic-openshift-sdn-ovs-3.9.33-1.git.0.c35d02e.el7.x86_64
atomic-openshift-clients-3.9.33-1.git.0.c35d02e.el7.x86_64
atomic-openshift-node-3.9.33-1.git.0.c35d02e.el7.x86_64



How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Gaoyun Pei 2018-07-18 03:05:32 UTC
According to Comment 2, rebuild the env without "_" in the instance name, the installation could be finished. So for 3.9 installation, instance names should also be RFC1123 compliant. Close this bug.


Note You need to log in before you can comment on or make changes to this bug.