Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601796 - [cloud-init][Aliyun] cloud-init still need patch for Aliyun BMS with RHEL6.9 [NEEDINFO]
Summary: [cloud-init][Aliyun] cloud-init still need patch for Aliyun BMS with RHEL6.9
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cloud-init
Version: 7.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Rick Barry
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-17 09:16 UTC by Chen Shi
Modified: 2018-09-06 15:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-06 15:24:33 UTC
Target Upstream Version:
ribarry: needinfo? (cheshi)


Attachments (Terms of Use)

Description Chen Shi 2018-07-17 09:16:22 UTC
Description of problem:
cloud-init cannot work normally on Aliyun BMS with RHEL6.9.

Version-Release number of selected component (if applicable):
cloud-init-0.7.5-8.el6_9.2.x86_64

RHEL Version:
RHEL6.9

How reproducible:
100%

Steps to Reproduce:
1. Create Instance on Aliyun BMS with RHEL6.9.
2. We can found the following issues:
   a) There is no outputs from showing cloud-init service status: [1]
      $ grep ^ sudo_service_cloud_*.log
      sudo_service_cloud_config_status_.log:Checking for service cloud-init:
      sudo_service_cloud_final_status_.log:Checking for service cloud-init:
      sudo_service_cloud_init_local_status_.log:Checking for service cloud-init:
      sudo_service_cloud_init_status_.log:Checking for service cloud-init:
   b) The following message has been found in /var/log/messages and /var/log/cloud-init-output.log:
      2018-07-16 13:35:07,366 - util.py[WARNING]: No instance datasource found! Likely bad things to come!
   c) cloud-init is failed to copy sshkey to the VM. As a result user cannot login with the sshkey credentials.
   d) cloud-init is failed to set the host name. As a result the host name is "localhost" instead.
   e) There is no message from /var/log/cloud-init.log and some brief
messages from /var/log/cloud-init-output.log

Actual results:
Something wrong with cloud-init services on Aliyun BMS with RHEL6.9.

Expected results:
cloud-init service should run without error.

Additional info:
[Vitaly] We have https://bugzilla.redhat.com/show_bug.cgi?id=1486548 - which is CLOSED CURRENTRELEASE and it seems something is still missing to support these instances. We'll likely need a new BZ.

Comment 3 Rick Barry 2018-09-06 15:24:33 UTC
Setting this to CLOSED-WONTFIX since we aren't supporting 6.* on bare metal instances.


Note You need to log in before you can comment on or make changes to this bug.