Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601734 - softlockup kernel-4.17.5
Summary: softlockup kernel-4.17.5
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-17 06:57 UTC by Bernhard Schuster
Modified: 2018-11-17 09:31 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-17 09:31:39 UTC


Attachments (Terms of Use)
Photo of the unresponsive machine's kernel trace (deleted)
2018-07-17 07:00 UTC, Bernhard Schuster
no flags Details

Description Bernhard Schuster 2018-07-17 06:57:30 UTC
Description of problem:
After upgrading to either 4.17.5 or 4.17.3 (not 100% sure which one started causing the issues) the system locks up after a couple of hours of use.


Version-Release number of selected component (if applicable):
kernel-4.17.5

How reproducible:
Mostly

Steps to Reproduce:
1. just keep the machine idle
2. BUG SOFTLOCKUP

Actual results:
Experience a SOFTLOCKUP

Expected results:
Being responsive on demand, such as ssh


Additional info:
I used to have this on Ryzen 1600, I since then upgraded to Ryzen 2 2600 which was working just fine until updating the system from 4.16.6 to 4.17.3/4.17.5 (again, not 100% sure which one, 4.17.3 was not used much).

Comment 1 Bernhard Schuster 2018-07-17 07:00:28 UTC
Created attachment 1459317 [details]
Photo of the unresponsive machine's kernel trace

Comment 2 ValdikSS 2018-07-17 10:39:48 UTC
Could you try with 4.17.3 please? I think it might be unrelated to Ryzen, I experience hard lockup on Intel platform with 4.17.5.

Comment 3 Bernhard Schuster 2018-07-17 18:50:02 UTC
4.17.3 seems to be fine so far.

I can also reproduce the SOFTLOCKUPs on Ivy Bridge/Haswell with 4.17.5 (can't try 4.17.3 there though).

Comment 4 ValdikSS 2018-07-17 19:57:38 UTC
Then it's https://bugzilla.redhat.com/show_bug.cgi?id=1598462

Comment 5 Bernhard Schuster 2018-07-18 06:09:35 UTC
Still running fine, so I guess this can be closed in favour of 1598462

Comment 6 Laura Abbott 2018-10-01 21:17:54 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.
 
Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.
 
If you experience different issues, please open a new bug report for those.

Comment 7 Bernhard Schuster 2018-11-17 09:31:39 UTC
So this was kernel upstream bug and got fixed a while ago.


Note You need to log in before you can comment on or make changes to this bug.