Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601712 - [converged] [CONSOLE-449] Cannot switch container in pod terminal
Summary: [converged] [CONSOLE-449] Cannot switch container in pod terminal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.11.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-17 05:38 UTC by shahan
Modified: 2018-10-11 07:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-11 07:21:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2652 None None None 2018-10-11 07:22:03 UTC

Description shahan 2018-07-17 05:38:00 UTC
Description of problem:
 The container selector was hidden by the terminal, the user cannot switch container if they want to change.

Version-Release number of selected component (if applicable):
v3.10.18
docker.io/openshift/origin-console                                        1f14ec53b95d

How reproducible:
Always

Steps to Reproduce:
1. oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/pods/pod_with_two_containers.json
2. goto pod's terminal page, try to switch 'hello-openshift-fedora' container terminal

Actual results:
2. The container selector was hidden by the terminal, cannot switch to another container.

Expected results:
could select another container

Additional info:

Comment 1 Jon Jackson 2018-07-20 18:05:48 UTC
pending fix https://github.com/openshift/console/pull/286

Comment 2 shahan 2018-07-23 09:10:41 UTC
checked line counts are accurate,move to verified.
docker.io/openshift/origin-console 889187ee7736

Comment 3 shahan 2018-07-23 09:14:28 UTC
sorry, the above comments are written in the wrong bug, this should be:
Pod terminal could switch containers now, so moved this bug to verified.
docker.io/openshift/origin-console 889187ee7736

Comment 5 errata-xmlrpc 2018-10-11 07:21:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2652


Note You need to log in before you can comment on or make changes to this bug.