Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601615 - VMs provisioned through VSphere are being discovered by CloudForms and assigned default group
Summary: VMs provisioned through VSphere are being discovered by CloudForms and assign...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Bronagh Sorota
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-16 22:43 UTC by Tuan
Modified: 2018-07-17 13:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-17 13:34:42 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Tuan 2018-07-16 22:43:03 UTC
Description of problem:
A VM is provisioned through VSphere and discovered through CloudForms. Selecting the VM shows the details that is a part of group "STSG Eng VSphere" under lifecycle


Ran test on reproducer: VM=tuanpitney2

[----] I, [2018-07-13T12:13:37.349750 #1971:cdb130]  INFO -- : MIQ(EmsRefresh.save_vms_inventory) EMS: [VBird], id: [1000000000023] Creating Vm [tuanpitney2] location: [tuanpitney2/tuanpitney2.vmx] storage id: [1000000000162] uid_ems: [4213e89a-207c-fec1-f1ae-f139a21264bd] ems_ref: [vm-541]

irb(main):003:0> ems = ManageIQ::Providers::Vmware::InfraManager.find_by(:name=>"VBird")
irb(main):004:0> vm = ems.vms.find_by(:name=>"tuanpitney2")
irb(main):007:0> vm.miq_group_id
=> 1000000000046
irb(main):012:0> group = MiqGroup.find_by(:id=>1000000000046)
=> #<MiqGroup id: 1000000000046, description: "STSG Eng VSphere", group_type: "user", sequence: 18, created_on: "2016-01-21 19:39:38", updated_on: "2016-01-21 19:39:38", settings: nil, tenant_id: 1000000000001>

Trying to figure out which method is causing the behavior to choose the specific group "STSG Eng VSphere"id: 1000000000046

Control policy does not seem to be setting the group.

Another test env shows discovered VM's not being assigned a group.

This seems like it might be caused by users, groups, and roles that are possibly overlapping


We suspect:

child.with_relationship_type('genealogy') { child.parent = parent } if parent && child


Version-Release number of selected component (if applicable):
5.8.2.1

How reproducible:
Everytime

Steps to Reproduce:
1.Provision VM through VSphere and wait for refresh in CloudForms
2.Click on discovered VM and see details showing default group (STSG Eng VSphere)
3.

Actual results:


Expected results:


Additional info:

Reproducer is available: 10.13.153.144  pw:smartvm

Comment 2 Tuan 2018-07-16 22:43:42 UTC
Created attachment 1459275 [details]
customers test


Note You need to log in before you can comment on or make changes to this bug.