Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160158 - bad: Grub doesn't load root
Summary: bad: Grub doesn't load root
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Coughlan
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-12 05:56 UTC by Murthy Vittala.
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:00:32 UTC


Attachments (Terms of Use)

Description Murthy Vittala. 2005-06-12 05:56:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; iebar; .NET CLR 1.0.3705)

Description of problem:
I use Adaptec raid card 3200s with two scsi hardisks implemeting RAID 1. I use dueal processor Intel servers with 1 GB Ram. 

The Redhat ES 3 loads the dpt_i2o driver perfectly and the setup completes with no errors repeating.

But when i reboot grub loads the initrd and just hangs on like that.......

My grub.conf looks like

root (hd0,0)
kernel /vmlinuz-2.4.21-4.ELsmp ro root=/dev/sda2 hdc=ide-scsi
initrd /initrd-2.4.21-4.ELsmp.img

fstab entries are

LABEL=/             /              ext3         defaults         1 1
Label=/boot         /boot          ext3         defaults         1 2
and so on........

I hope grub is not finding out the root....

When i boot with the floppy

i get the error messages stating 

VFS: can't find ext2 filesystem on dev loop(7,0)
kernel panic and so on...........


I hunged up in middle instead getting the High-end server....

Thanks for the advanced help...

Version-Release number of selected component (if applicable):
kernel-2.4.21-4.ELsmp

How reproducible:
Always

Steps to Reproduce:
1.often
2.
3.
  

Additional info:

Comment 1 Suzanne Hillman 2005-06-13 15:52:08 UTC
As you appear to be looking for support, please either contact Red Hat's Technical
Support line at 888-REDHAT-1 or file a web ticket at
http://www.redhat.com/apps/support/.  Bugzilla is not an official support
channel, has no response guarantees, and may not route your issue to the correct
area to assist you.  Using the official support channels above will guarantee
that your issue is handled appropriately and routed to the individual or group
which can best assist you with this issue and will also allow Red Hat to track
the issue, ensuring that any applicable bug fix is included in all releases and
is not dropped from a future update or major release.

Comment 3 RHEL Product and Program Management 2007-10-19 19:00:32 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.