Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160154 - upgrade from FC3 to FC4 fails for screen
Summary: upgrade from FC3 to FC4 fails for screen
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-12 03:38 UTC by Chris Ricker
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-31 21:44:13 UTC


Attachments (Terms of Use)
Upgrade.log from the offending host (deleted)
2005-06-16 20:55 UTC, Jacek Piskozub
no flags Details
upgrade log (deleted)
2005-06-17 15:27 UTC, Chris Ricker
no flags Details

Description Chris Ricker 2005-06-12 03:38:51 UTC
Upgrading from FC3 to FC4 gives the following error:

Upgrading screen-4.0.2-9.i386.
groupadd: unable to open group file
error: %pre(screen-4.0.2-9.i386) scriptlet failed, exit status 10
error:   install: %pre scriptlet failed (2), skipping screen-4.0.2-9

as a result, screen doesn't get upgraded from the FC3 version (screen-4.0.2-5)

Comment 2 Bill Nottingham 2005-06-12 21:25:01 UTC
Are you using SELinux?

How are you upgrading?

Comment 3 Chris Ricker 2005-06-13 02:20:26 UTC
on that machine, selinux is disabled (in /etc/sysconfig/selinux)

upgrade was done using anaconda from CD

manually doing the groupadd and then rpm -Fvh on the package worked after
booting into FC4

I've not seen this with any other systems so far....

Comment 4 Bill Nottingham 2005-06-13 02:23:47 UTC
Assigning to anaconda, but may get closed as a unreproducible bogon if it
doesn't happen on any other machines. I really can't see how this would happen.

Comment 5 Jacek Piskozub 2005-06-15 10:16:36 UTC
It does happen. After a upgrade from fc3 to fc4 I found the following in
/root/upgrade-log:

Upgrading screen-4.0.2-9.i386.
groupadd: unable to open group file
error: %pre(screen-4.0.2-9.i386) scriptlet failed, exit status 10
error:   install: %pre scriptlet failed (2), skipping screen-4.0.2-9


The first "yum update" after the upgrade did manage to update screen with no
glitches.

Comment 6 Jeremy Katz 2005-06-16 20:03:48 UTC
Can you provide the complete upgrade.log?  I think this might be due to a bug in
groupadd which I fixed during the FC4 cycle

Comment 7 Jacek Piskozub 2005-06-16 20:55:13 UTC
Created attachment 115575 [details]
Upgrade.log from the offending host

I'm not sure how it will help you. BTW, since I posted my comment I've made two
more fc3->fc4 upgrades and I've seen the problem one one of them as well.

Comment 8 Jacek Piskozub 2005-06-16 21:04:43 UTC
You probably mean this bug:

* Sat Apr 30 2005 Jeremy Katz <katzj@redhat.com> - 2:4.0.7-7
- don't assume selinux is enabled if is_selinux_enabled() returns -1

Yes, I do have selinux disbled. And my shadow-utils before the upgrade was
shadow-utils-4.0.3-56.rpm built on December 4, 2004.

Comment 9 Chris Ricker 2005-06-17 15:27:10 UTC
Created attachment 115613 [details]
upgrade log

upgrade log from one of the systems which did this

Comment 10 Chris Lumens 2006-03-29 17:01:47 UTC
Are you still seeing upgrade problems with FC5?

Comment 11 Chris Ricker 2006-03-31 21:42:45 UTC
fc4 -> fc5 went fine


Note You need to log in before you can comment on or make changes to this bug.