Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160150 - ldap server does no start
Summary: ldap server does no start
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: authconfig
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL: none
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-11 22:26 UTC by misteros2
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-12 17:53:11 UTC


Attachments (Terms of Use)

Description misteros2 2005-06-11 22:26:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050422 Red Hat/1.7.7-1.4.2

Description of problem:
installing pristine rhel4-u1
ldap server fails to start
output in log:
Jun 11 22:19:42 srv142 slaptest: bdb_initialize: Sleepycat Software: Berkeley DB 4.2.52: (December
3, 2003)
Jun 11 22:19:42 srv142 slaptest: bdb_initialize: Sleepycat Software: Berkeley DB 4.2.52: (December
3, 2003)
Jun 11 22:19:42 srv142 ldap:  succeeded
Jun 11 22:19:42 srv142 slapd[3403]: @(#) $OpenLDAP: slapd 2.2.13 (Aug 19 2004 21:22:15) $       root@porky.build.redhat.com:/usr/src/build/440386-i386/BUILD/openldap-2.2.13/openldap-2.2.13/build-servers/servers/slapd
Jun 11 22:19:42 srv142 slapd[3403]: bdb_initialize: Sleepycat Software: Berkeley DB 4.2.52: (December  3, 2003)
Jun 11 22:19:42 srv142 slapd[3403]: bdb_initialize: Sleepycat Software: Berkeley DB 4.2.52: (December  3, 2003)
Jun 11 22:19:42 srv142 slapd[3403]: main: TLS init def ctx failed: -1
Jun 11 22:19:42 srv142 slapd[3403]: slapd stopped.
Jun 11 22:19:42 srv142 slapd[3403]: connections_destroy: nothing to destroy.
Jun 11 22:19:42 srv142 ldap: slapd startup failed


Version-Release number of selected component (if applicable):
openldap 2.2.13-2

How reproducible:
Always

Steps to Reproduce:
my slapd.conf:

  #
include         /etc/openldap/schema/core.schema
include         /etc/openldap/schema/cosine.schema
include         /etc/openldap/schema/inetorgperson.schema
include         /etc/openldap/schema/nis.schema
include         /etc/openldap/schema/redhat/autofs.schema
# extras
include         /etc/openldap/schema/samba.schema

database        ldbm
directory       /var/lib/ldap

suffix          "dc=cid,dc=net"
rootdn          "cn=root,dc=cid,dc=net"
rootpw          secret 

cachesize       100000
dbcachesize     1000000
sizelimit       100
timelimit       360
#loglevel        0

pidfile /var/run/slapd.pid
argsfile /var/run/slapd/slapd.args

index   objectClass             eq
index   cn                      pres,sub,eq
index   sn                      pres,sub,eq
index   uid                     pres,sub,eq
index   displayName             pres,sub,eq
index   uidNumber               eq
index   gidNumber               eq
index   memberUID               eq
index   sambaSID                eq
index   sambaPrimaryGroupSID    eq
index   sambaDomainName         eq
index   default                 sub


Expected Results:  when installing previous rhel4: no problem

Additional info:

Comment 1 Yasuma Takeda 2005-07-19 11:50:09 UTC
Hi,

I guess you should remove "TLS_CACERTDIR /etc/openldap/cacerts" from
/etc/openldap/ldap.conf.
It may resolve your problem.

The behaviour of nss_ldap was changed from nss_ldap-226-1 to nss_ldap-226-6.


Comment 2 Joe Orton 2005-08-04 11:54:37 UTC
This appears to be caused by authconfig, which is adding the TLS_CACERTDIR
setting to the system ldap.conf, even though the directory it references does
not exist.

Comment 4 Tomas Mraz 2005-08-04 13:17:49 UTC
Authconfig probably shouldn't add this config directive to ldap.conf if TLS is
not on, however the directory should be a part of openldap package anyway. This
directory should be probably created anyway because already broken
configurations cannot be fixed by simple authconfig upgrade.


Comment 5 Tomas Mraz 2005-08-04 13:49:55 UTC
Also see bug 159151 - basically a duplicate.


Comment 8 Tomas Mraz 2005-10-12 17:53:11 UTC
This will be fixed also in authconfig in the next RHEL release. (Already fixed
in Fedora Core development.)



Note You need to log in before you can comment on or make changes to this bug.