Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160144 - rpm should have a BuildReq on gettext-devel
Summary: rpm should have a BuildReq on gettext-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
: 164681 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-11 14:34 UTC by Roozbeh Pournader
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-28 19:46:35 UTC


Attachments (Terms of Use)

Description Roozbeh Pournader 2005-06-11 14:34:37 UTC
Description of problem:
Building RPM from the FC4 branch in the fedora CVS fails.

Version-Release number of selected component (if applicable):
rpm-4.4.1-21

How reproducible:
Always

Steps to Reproduce:
1. cvs co FC-4
2. cd rpm
3. make i386
  
Actual results:
Build fails with an error message ending in the following:
Making all in popt
make[3]: Entering directory `/home/roozbeh/FC-4/rpm/rpm-4.4.1/popt'
cd . && /bin/sh /home/roozbeh/FC-4/rpm/rpm-4.4.1/popt/missing --run aclocal-1.9
aclocal:configure.ac:90: warning: macro `AM_GNU_GETTEXT' not found in library
 cd . && /bin/sh /home/roozbeh/FC-4/rpm/rpm-4.4.1/popt/missing --run
automake-1.9 --foreign
cd . && /bin/sh /home/roozbeh/FC-4/rpm/rpm-4.4.1/popt/missing --run autoconf
configure.ac:90: error: possibly undefined macro: AM_GNU_GETTEXT
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
make[3]: *** [configure] Error 1
make[3]: *** Waiting for unfinished jobs....
configure.ac:4: not enough arguments for AC_CONFIG_HEADERS
make[3]: Leaving directory `/home/roozbeh/FC-4/rpm/rpm-4.4.1/popt'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/roozbeh/FC-4/rpm/rpm-4.4.1'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/roozbeh/FC-4/rpm/rpm-4.4.1'
error: Bad exit status from /var/tmp/rpm-tmp.97529 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.97529 (%build)
make: *** [i386] Error 1

Comment 1 Roozbeh Pournader 2005-06-11 14:59:34 UTC
It seems that this is actually a missing BuildReq on gettext-devel.

Comment 2 Paul Bolle 2005-07-14 23:26:04 UTC
1) I can confirm this is just a missing BuildRequires on gettext-devel.
2) This bug is still present in FC4 (as it also has rpm-4.4.1-21).
3) Should I file a bug against FC4 to make sure this bug also shows up when
querying on FC4 (just as I did before finding this report)? That report could be
closed as a dupe right away, of course ...
4) Anyway, should be trivial to patch (which I still would be happy to do).

Comment 3 Roozbeh Pournader 2005-07-16 13:49:46 UTC
Changing Version to FC4, based on pebolle's comment.

Comment 4 Paul Bolle 2005-07-30 22:01:17 UTC
OT: can't all testing bugs be automatically upgraded to their successor 
(test1->test2->test3->release) whenever a new test release and/or (just) the
final release is available? At least, I assume that test releases are only
(really) useful until the next (test) release.

Comment 5 Jeff Johnson 2005-09-29 19:49:24 UTC
*** Bug 164681 has been marked as a duplicate of this bug. ***

Comment 6 Paul Nasrat 2005-11-28 19:46:35 UTC
rawhide rpm.spec has this BuildReq.


Note You need to log in before you can comment on or make changes to this bug.