Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601398 - Unable to mount volumes for pod "pod-name (pod_uuid)": timeout expired waiting for volumes
Summary: Unable to mount volumes for pod "pod-name (pod_uuid)": timeout expired waitin...
Keywords:
Status: CLOSED DUPLICATE of bug 1583673
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.7.0
Hardware: Unspecified
OS: Linux
medium
high
Target Milestone: ---
: 3.7.z
Assignee: Jan Safranek
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-16 10:29 UTC by Mahesh Taru
Modified: 2018-07-20 08:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-20 08:35:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mahesh Taru 2018-07-16 10:29:53 UTC
Description of problem:
Mounting Secrets/Tokens/Volumes are intermittently taking a long time being reclaimed/recycled.
This seems like normal cluster operation but the deployment slowdowns are getting worst by the day.

Version-Release number of selected component (if applicable):
oc version
oc v3.7.23
kubernetes v1.7.6+a08f5eeb62
features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible:

Steps to Reproduce:
1. Create/Select project 
2. Create pc & pvc using AWS nfs share
3. Deploy application or Add pvc to existing pods.

Actual results:
Users are experiencing very slow deployments, either clicking Deploy or via scaling down/up - 5/10 minutes or more. durationBeforeRetry 2m2s is being hit therefore things seem to be getting rate limited/throttled.
Node logs are showing several MountVolume.SetUp failed for volume [volumex, y, z]

Expected results:
Deployment shouldn't take more than ~2 minutes?

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 9 Jan Safranek 2018-07-20 08:35:31 UTC

*** This bug has been marked as a duplicate of bug 1583673 ***


Note You need to log in before you can comment on or make changes to this bug.