Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601392 - fakeroot 1.22+ t.tar test is failing
Summary: fakeroot 1.22+ t.tar test is failing
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: fakeroot
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-16 10:12 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2018-11-30 10:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 10:43:08 UTC


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2018-07-16 10:12:51 UTC
Description of problem:
fakeroot test t.tar is failing.

Version-Release number of selected component (if applicable):
fakeroot-1.22-2.fc28

How reproducible:
Always.

Steps to Reproduce:
1. Run the testsuite (or rebuild the package) with gcc >= 7.3.1

Actual results:
[...]
make[3]: Entering directory '/builddir/build/BUILD/fakeroot-1.23/obj-sysv/test'
PASS: t.chmod_dev
PASS: t.echoarg
PASS: t.falsereturn
PASS: t.mknod
PASS: t.no_ld_preload
PASS: t.no_ld_preload_link
PASS: t.option
FAIL: t.tar
PASS: t.touchinstall
PASS: t.truereturn
PASS: t.xattr
========================================
   fakeroot 1.23: test/test-suite.log
========================================

# TOTAL: 11
# PASS:  10
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: t.tar
===========

tartest:
compare-tar:
tar files differ:
13c13,17
< rw-r--r-- root/root 0 tar/1.file
---
> rw-r--r-- daemon/sys 0 tar/1.file
> rw-r--r-- daemon/sys 0 tar/3.file
> rw-r--r-- daemon/sys 0 tar/5.file
> rw-r--r-- daemon/sys 0 tar/fjsdk.file
> rw-r--r-- daemon/sys 0 tar/vn.34.654l..file
18d21
< rw-r--r-- root/root 0 tar/3.file
20d22
< rw-r--r-- root/root 0 tar/5.file
24d25
< rw-r--r-- root/root 0 tar/fjsdk.file
35d35
< rw-r--r-- root/root 0 tar/vn.34.654l..file
FAIL t.tar (exit status: 1)

============================================================================
Testsuite summary for fakeroot 1.23
============================================================================
# TOTAL: 11
# PASS:  10
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See test/test-suite.log
Please report to clint@debian.org
============================================================================
make[3]: *** [Makefile:548: test-suite.log] Error 1
make[3]: Leaving directory '/builddir/build/BUILD/fakeroot-1.23/obj-sysv/test'

Expected results:
All tests pass.

Additional info:
This is also reproducible with fakeroot-1.23.

It looks like it started failing after gcc 7.2.1 -> 7.3.1 update:
https://apps.fedoraproject.org/koschei/package/fakeroot?last_seen_ts=1517889997&collection=f29

And it seems upstream hasn't tested with gcc > 7.3.0 yet:
https://packages.debian.org/sid/gcc
https://buildd.debian.org/status/package.php?p=fakeroot

Reported to upstream author (Clint Adams) today (2018-07-16).

Comment 1 Jan Kurik 2018-08-14 09:53:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Dominik 'Rathann' Mierzejewski 2018-11-30 10:43:08 UTC
Looks whatever was brlike it is fixed, I can no longer reproduce it on rawhide or on F29, closing.


Note You need to log in before you can comment on or make changes to this bug.