Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601359 - libguestfs error: filesize: /var/lib/rpm/Name: No such file or directory
Summary: libguestfs error: filesize: /var/lib/rpm/Name: No such file or directory
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-16 07:43 UTC by Haigang
Modified: 2018-07-16 08:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-16 08:53:35 UTC


Attachments (Terms of Use)
error.log (deleted)
2018-07-16 07:43 UTC, Haigang
no flags Details

Description Haigang 2018-07-16 07:43:31 UTC
Created attachment 1459061 [details]
error.log

Description of problem:

command:
  $ sudo virt-v2v   -i libvirtxml "/v2v/data/redhat6.2/redhat6.2.xml"  -o local -os "/v2v/target/redhat6.2" -of qcow2

The error message:
  virt-v2v: error: libguestfs error: filesize: /var/lib/rpm/Name: No such
file or directory

Version-Release number of selected component (if applicable):

libguestfs-hfsplus:amd64             1:1.38.1-1
libguestfs-perl                      1:1.38.1-1
libguestfs-reiserfs:amd64            1:1.38.1-1
libguestfs-tools                     1:1.38.1-1
libguestfs-xfs:amd64                 1:1.38.1-1
libguestfs0:amd64                    1:1.38.1-1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Pino Toscano 2018-07-16 08:29:24 UTC
(In reply to Haigang from comment #0)
> command:
>   $ sudo virt-v2v   -i libvirtxml "/v2v/data/redhat6.2/redhat6.2.xml"  -o
> local -os "/v2v/target/redhat6.2" -of qcow2

First of all, note that if your guest was already running in libvirt, then you do not need virt-v2v at all -- just import it to the target libvirt/hypervisor.

The guest seems to be RHEL 6.2, but /var/lib/rpm/Name is not available there.
Is yum/rpm running fine in that guest? I see /var is in a separate partition, can you please check that /lib/rpm/Name exists in that partition?

Comment 2 Haigang 2018-07-16 08:53:35 UTC
I know why this is.

The guest is redhat 6.2, Is not  rhel 6.2.

So, Libguestfs does not support it.

I apologize to you for asking this stupid question.


Note You need to log in before you can comment on or make changes to this bug.