Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160130 - Error when propagating restored configuration file
Summary: Error when propagating restored configuration file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-11 00:44 UTC by Paul Kennedy
Modified: 2015-04-20 00:46 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-1060
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-21 21:55:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:1060 normal SHIPPED_LIVE system-config-cluster bug fix update 2007-11-29 14:47:41 UTC

Description Paul Kennedy 2005-06-11 00:44:05 UTC
Description of problem:

--------
Symptom
--------
When trying to restore the configuration file from a backup configuration file,
the propagation is not successful. Received Error dialog box that indicated
failure to propagate because "Proposed updated config file does not have greater
version number."

-----------
Workaround
-----------

Unkown. Tried clicking "Send to Cluster" two more times. On second try the
propagation was successful; presumably though, that was because the
configuration file got saved automatically by the action of clicking "Send to
Cluster".


Version-Release number of selected component (if applicable):
system-config-cluster 1.0.12 

How reproducible:


Steps to Reproduce:
1.  Added service "alpha".
2.  Clicked "Send to Cluster" and acknowledged resultant dialog box with "Yes".
3.  Added service "beta".
4.  Clicked "Send to Cluster" and acknowledged resultant dialog box with "Yes".
5.  Added service "charlie".
6.  Clicked "Send to Cluster" and acknowledged resultant dialog box with "Yes".
7.  At the Cluster Configuration tab, did File => Open =>
    /etc/cluster.conf.bak.3 
8.  At the Cluster Configuration tab, did File => Save As => /etc/cluster.conf
9.  Clicked "Send to Cluster" and acknowledged resultant dialog box with "Yes".
10. Acknowledging dialog box with "Yes" caused an Error dialog box to be
    displayed with the following message:
---------------------------------------------------------------------
Propagation of configuration file failed with the following error:
 Proposed updated config file does not have greater version number.
  Current config_version :: 269
  Proposed config_version:: 268

Failed to update config file.
---------------------------------------------------------------------


Actual results:


Expected results:


Additional info:

Comment 1 Paul Kennedy 2005-06-15 17:41:47 UTC
The procedure for restoring to a backup configuration file should include a step
to increment the configuration file revision level to a number beyond the
current revision level. Documentation has been changed to reflect that. 

Changed severity to "enhancement", however. Recommend that restoring a file from
a backup file automatically update the revision level.

Comment 2 Paul Kennedy 2006-02-01 23:11:50 UTC
Please reassign this bug to me if the change is made so I can adjust the
documentation to exclude step 4 for changing the rev level:

http://www.redhat.com/docs/manuals/csgfs/browse/rh-cs-en/s1-admin-backup.html

Comment 4 Kiersten (Kerri) Anderson 2007-01-04 17:18:12 UTC
Due to time constraints and impact on documentation, moving this to 4.6 release.

Comment 5 Jim Parsons 2007-09-25 14:43:06 UTC
This is fixed for 4.6. Added an increment call to revision number. easier than I
thought. No need to alter documentation.

Comment 10 errata-xmlrpc 2007-11-21 21:55:08 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1060.html



Note You need to log in before you can comment on or make changes to this bug.