Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601278 - SELinux is preventing mount from 'ioctl' accesses on the blk_file /dev/loop0.
Summary: SELinux is preventing mount from 'ioctl' accesses on the blk_file /dev/loop0.
Keywords:
Status: CLOSED DUPLICATE of bug 1601276
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:47412a19fd9c2d8b8b940a7a513...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-15 21:45 UTC by shmuel
Modified: 2019-03-27 12:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-22 11:43:28 UTC


Attachments (Terms of Use)

Description shmuel 2018-07-15 21:45:44 UTC
Description of problem:
SELinux is preventing mount from 'ioctl' accesses on the blk_file /dev/loop0.

*****  Plugin catchall (100. confidence) suggests   **************************

Si cree que de manera predeterminada se debería permitir a mount el acceso ioctl sobre  loop0 blk_file.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso temporalmente ejecutando:
# ausearch -c 'mount' --raw | audit2allow -M mi-mount
# semodule -X 300 -i mi-mount.pp

Additional Information:
Source Context                system_u:system_r:snappy_t:s0
Target Context                system_u:object_r:fixed_disk_device_t:s0
Target Objects                /dev/loop0 [ blk_file ]
Source                        mount
Source Path                   mount
Port                          <Desconocido>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-32.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.17.5-200.fc28.x86_64 #1 SMP Tue
                              Jul 10 13:39:04 UTC 2018 x86_64 x86_64
Alert Count                   2
First Seen                    2018-07-15 16:31:51 CDT
Last Seen                     2018-07-15 16:35:40 CDT
Local ID                      bf01e022-8daa-4147-9c50-e807a53c0609

Raw Audit Messages
type=AVC msg=audit(1531690540.829:238): avc:  denied  { ioctl } for  pid=2385 comm="mount" path="/dev/loop0" dev="devtmpfs" ino=42997 ioctlcmd=0x4c00 scontext=system_u:system_r:snappy_t:s0 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file permissive=1


Hash: mount,snappy_t,fixed_disk_device_t,blk_file,ioctl

Version-Release number of selected component:
selinux-policy-3.14.1-32.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.17.5-200.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-07-22 11:43:28 UTC

*** This bug has been marked as a duplicate of bug 1601276 ***

Comment 2 jinyang.zou 2019-03-27 12:27:57 UTC
*** Bug 1693267 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.