Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601254 - Crashes when "Save Image As..." is selected
Summary: Crashes when "Save Image As..." is selected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox
Version: 6.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Horak
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-15 16:28 UTC by Robert Nichols
Modified: 2018-08-21 07:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-25 08:25:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Nichols 2018-07-15 16:28:33 UTC
Description of problem:
Trying to save an image from a web page causes a crash

Version-Release number of selected component (if applicable):
firefox-60.1.0-5.el6.centos.x86_64

How reproducible:
Always

Steps to Reproduce:
1. View any web page containing a JPG image
2. Right-click on the image
3. Select "Save Image As..." in the menu

Actual results:
Firefox crashes

Expected results:
No crash, image saved.

Additional info:

Comment 2 Robert Nichols 2018-07-15 16:53:07 UTC
Messages from firefox:
(firefox:3401): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
[Child 3502, Chrome_ChildThread] WARNING: pipe error (3): Connection reset by peer: file /builddir/build/BUILD/firefox-60.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
Trace/breakpoint trap (core dumped)

Comment 3 Robert Nichols 2018-07-16 02:40:04 UTC
Apparently the same problem as bug 1596852. The patch in https://bugzilla.redhat.com/show_bug.cgi?id=1596852#c0 corrects the error.

Comment 4 Martin Stransky 2018-07-25 08:25:42 UTC
That was fixed by firefox-60.1.0-6.el6 packages:
https://access.redhat.com/errata/RHBA-2018:2218

Comment 5 Jan Horak 2018-08-21 07:28:34 UTC
*** Bug 1611808 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.