Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1601206 - Unable to deploy from private Docker Hub image
Summary: Unable to deploy from private Docker Hub image
Keywords:
Status: CLOSED DUPLICATE of bug 1600539
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.9.0
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.9.z
Assignee: Maciej Szulik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-15 05:12 UTC by Patrick Kayongo
Modified: 2018-08-20 13:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 10:28:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Patrick Kayongo 2018-07-15 05:12:56 UTC
Description of problem:

I am unable to deploy an application from a private docker hub image. The image stream can correctly read the image (as it gets the image metadata), but the deployment fails.

Version-Release number of selected component (if applicable):

v3.9.31 

How reproducible:



Steps to Reproduce:
oc secrets new my-dockerhub-secret .dockerconfigjson=/root/.docker/config.json
oc secrets add sa/default secrets/my-dockerhub-secret --for=pull
oc new-app --docker-image <registry>/image:tag

Actual results:

I get the following error:

Warning  Failed                 24s (x3 over 1m)  kubelet, node.my.org.co  Failed to pull image "docker.io/myorg/myimage@sha256:5d7....f4": rpc error: code = Unknown desc = repository docker.io/myorg/myimage not found: does not exist or no pull access

Expected results:

A successful deployment.


Additional info:

Comment 1 Michal Fojtik 2018-07-20 12:27:19 UTC
If you have an image stream, why don't you use a image stream change trigger for the deployment config? (Or alternatively you can oc set image).

Comment 2 Xingxing Xia 2018-07-23 06:16:22 UTC
Were reported:
Bug 1561989 (3.10)
Bug 1600539 (3.9)

Comment 3 Patrick Kayongo 2018-07-23 06:36:14 UTC
If a bug has been reported, does this mean a fix can be expected?

Comment 4 Xingxing Xia 2018-07-24 06:23:26 UTC
Looks like the Dev for the Bug 1600539 could give the info.

Comment 5 Maciej Szulik 2018-07-27 10:28:26 UTC
I'm closing this as a duplicate of Bug 1600539.

*** This bug has been marked as a duplicate of bug 1600539 ***


Note You need to log in before you can comment on or make changes to this bug.