Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160119 - Missing BuildRequires on gcc-c++
Summary: Missing BuildRequires on gcc-c++
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 20:16 UTC by Brent Fox
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-13 14:48:58 UTC


Attachments (Terms of Use)

Description Brent Fox 2005-06-10 20:16:08 UTC
I assume this bug applies to Xorg in RHEL4 and FC as well.

I installed the XFree86 SRPM and then installed all the build requirements. 
When I tried rebuilding XFree-4.3.0 from source, the build failed midway through
because it could not find "c++".  Installing gcc-c++ fixed the problem.

I did not install it initially because I did not think there was any C++ code in
XFree86.  Adding a BuildRequires in the specfile will fix this problem.

Comment 1 Mike A. Harris 2005-06-13 14:48:58 UTC
Our rpm packages intentionally do not ever explicitly BuildRequire C or C++
compilers, as they are expected to be installed on "developmental" machines
as part of the base devel packages.  When installing, be sure to select
the development categories, and the compilers should properly be installed.

I've confirmed this is the correct behaviour with Bill Nottingham as well,
just to be sure our policy on issues of this nature haven't changed.

Setting status to NOTABUG.

>I did not install it initially because I did not think there was any C++ code 
>in XFree86.

libGLU, supplied with Mesa which is part of XFree86 and X.Org, is written
in C++.  That's the only C++ code included in the tree however.


Note You need to log in before you can comment on or make changes to this bug.