Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160116 - php Unserialize Problem with References
Summary: php Unserialize Problem with References
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: http://bugs.php.net/22245
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 19:52 UTC by Chuck P
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:00:35 UTC


Attachments (Terms of Use)

Description Chuck P 2005-06-10 19:52:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
When I add a $_SESSION variable to another php $_SESSION by reference the data is lost on page refresh.  The references between $_SESSION entries are never reestablished. This is documented at bugs.php.net as fixed in 4.3.3 bug #22245 http://bugs.php.net/bug.php?id=22245


Version-Release number of selected component (if applicable):
php-4.3.2 / kernel-2.4.9-e.62

How reproducible:
Always

Steps to Reproduce:
Steps for reproducing bug is posted at bugs.php.net as fixed in 4.3.3 bug #22245 http://bugs.php.net/bug.php?id=22245
  

Actual Results:  The references between $_SESSION entries are never reestablished.

Expected Results:  The references between $_SESSION entries SHOULD be reestablished.

Additional info:

With object orientated programing this is a common use for php programmers.  I have not run into the problem before since I have been working on newer versions.  I am now working for North Dakota State University using Redhat Enterprise Linux version 3 which runs php-4.3.2 and I realy would appreciate this update.

Comment 1 RHEL Product and Program Management 2007-10-19 19:00:35 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.