Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160114 - Burn stops, fails, as non-root
Summary: Burn stops, fails, as non-root
Keywords:
Status: CLOSED DUPLICATE of bug 208542
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrtools
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 19:28 UTC by Andrew
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-29 10:27:21 UTC


Attachments (Terms of Use)
Default K3B on FC4 Test 3 (deleted)
2005-06-10 19:28 UTC, Andrew
no flags Details
K3B 0.12beta2 1st fail (deleted)
2005-06-10 19:30 UTC, Andrew
no flags Details
K3B 0.12beta2 1st fail (deleted)
2005-06-10 19:30 UTC, Andrew
no flags Details
K3B 0.12beta2 2nd fail (deleted)
2005-06-10 19:44 UTC, Andrew
no flags Details
K3B 0.12beta2 3rd fail (deleted)
2005-06-10 19:45 UTC, Andrew
no flags Details
K3B 0.12beta2 using cdrtools-2.01.01a03.tar.bz2 from http://cdrecord.berlios.de (deleted)
2005-06-10 19:52 UTC, Andrew
no flags Details

Description Andrew 2005-06-10 19:28:58 UTC
Description of problem:
Burner (Pioneer DVR-106D in LaCie external USB2.0) stops burning (light goes
off), then K3B times-out, then closes the session.  Burning fails.

Version-Release number of selected component (if applicable):
cdrtools-2.01.1-9, cdrtools-2.01.01.a03

How reproducible:
Every time.

Steps to Reproduce:
1.  Load K3B
2.  Select Tools->Burn CD-> Burn CD Image
3.  Click burn
  
Actual results:
After a random amount of time, CD burning stops, times out, then fails when
burning as non-root.

Expected results:
Burn completes.

Additional info:
See attached files.  Tried upgrading K3B, then cdrtools to latest version.  Had
to "modprobe sg" as root to get around error described in Bug# 138739, Comments#
4 and 6.

K3B as root works.

Comment 1 Andrew 2005-06-10 19:28:59 UTC
Created attachment 115304 [details]
Default K3B on FC4 Test 3

Comment 2 Andrew 2005-06-10 19:30:30 UTC
Created attachment 115305 [details]
K3B 0.12beta2 1st fail

Comment 3 Andrew 2005-06-10 19:30:58 UTC
Created attachment 115306 [details]
K3B 0.12beta2 1st fail

Comment 4 Andrew 2005-06-10 19:44:08 UTC
Created attachment 115307 [details]
K3B 0.12beta2 2nd fail

Comment 5 Andrew 2005-06-10 19:45:32 UTC
Created attachment 115308 [details]
K3B 0.12beta2 3rd fail

Comment 6 Andrew 2005-06-10 19:52:11 UTC
Created attachment 115309 [details]
K3B 0.12beta2 using cdrtools-2.01.01a03.tar.bz2 from http://cdrecord.berlios.de

Seems like "root" doesn't always work after all.  Here is the output from the
second coaster I've burned using Iomega 700MB media (FAIL-4)...

Note the different error messages between the 1st and the 4th failures:

/usr/bin/cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 05 6F C8 00 00 1A 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0E 00 00 00 00 21 02 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x21 Qual 0x02 (invalid address for write) Fru 0x0
Sense flags: Blk 0 (not valid) 


/usr/bin/cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 3C 2F 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0E 00 00 00 00 2C 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x2C Qual 0x00 (command sequence error) Fru 0x0
Sense flags: Blk 0 (not valid) 


--driver: Input/output error.  : scsi sendcmd: no error
CDB:  2A 00 00 00 8A 93 00 00 1A 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0E 00 00 00 00 2C 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x2C Qual 0x00 (command sequence error) Fru 0x0
Sense flags: Blk 0 (not valid) 


/usr/bin/cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 01 37 D1 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0E 00 00 00 00 2C 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x2C Qual 0x00 (command sequence error) Fru 0x0
Sense flags: Blk 0 (not valid)

Comment 7 Harald Hoyer 2006-09-29 10:27:21 UTC

*** This bug has been marked as a duplicate of 208542 ***


Note You need to log in before you can comment on or make changes to this bug.