Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600718 - SELinux is preventing upowerd from read, write, open access on the file /var/lib/upower/history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ.
Summary: SELinux is preventing upowerd from read, write, open access on the file /var/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5691c083b5b8f9a574087b6ca18...
: 1600714 1600715 1600716 1600717 1600719 1600720 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 20:30 UTC by Mikhail
Modified: 2018-09-12 02:58 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.14.2-34.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 02:58:18 UTC


Attachments (Terms of Use)

Description Mikhail 2018-07-12 20:30:17 UTC
Description of problem:
SELinux is preventing upowerd from read, write, open access on the file /var/lib/upower/history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that upowerd should be allowed read write open access on the history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'upowerd' --raw | audit2allow -M my-upowerd
# semodule -X 300 -i my-upowerd.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:devicekit_var_lib_t:s0
Target Objects                /var/lib/upower/history-rate-Sony_Interactive_Ente
                              rtainment_Wireless_Controller-f4:93:9f:56:03:cb.da
                              t.I1KBMZ [ file ]
Source                        upowerd
Source Path                   upowerd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.2-26.fc29.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.18.0-0.rc0.git9.1.fc29.x86_64 #1
                              SMP Thu Jun 14 18:07:49 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-07-11 08:41:20 +05
Last Seen                     2018-07-11 08:41:20 +05
Local ID                      b1d62f05-1661-4989-8f4f-14240c911a53

Raw Audit Messages
type=AVC msg=audit(1531280480.721:499): avc:  denied  { read write open } for  pid=1278 comm="upowerd" path="/var/lib/upower/history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ" dev="sdc1" ino=6160472 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:devicekit_var_lib_t:s0 tclass=file permissive=1


Hash: upowerd,init_t,devicekit_var_lib_t,file,read,write,open

Version-Release number of selected component:
selinux-policy-3.14.2-26.fc29.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.18.0-0.rc4.git3.1.local.fc29.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-07-22 11:38:45 UTC
*** Bug 1600714 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2018-07-22 11:38:48 UTC
*** Bug 1600715 has been marked as a duplicate of this bug. ***

Comment 3 Lukas Vrabec 2018-07-22 11:38:51 UTC
*** Bug 1600716 has been marked as a duplicate of this bug. ***

Comment 4 Lukas Vrabec 2018-07-22 11:38:56 UTC
*** Bug 1600717 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Vrabec 2018-07-22 11:39:02 UTC
*** Bug 1600719 has been marked as a duplicate of this bug. ***

Comment 6 Lukas Vrabec 2018-07-22 11:39:06 UTC
*** Bug 1600720 has been marked as a duplicate of this bug. ***

Comment 7 Jan Kurik 2018-08-14 11:16:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 8 Fedora Update System 2018-09-11 12:51:58 UTC
selinux-policy-3.14.2-34.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-db240a1726

Comment 9 Fedora Update System 2018-09-12 02:58:18 UTC
selinux-policy-3.14.2-34.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.